Hi, Leonid Lisovskiy wrote, > On Tue, Jun 21, 2016 at 10:10 PM, Waldemar Brodkorb <[email protected]> > wrote: > > Hi Leonid, > > Leonid Lisovskiy wrote, > > > >> Previously, DL_OPENED flag was set in libdl only and never used. > >> Set it centralized in _dl_load_elf_shared_library() & use it in > >> both ld.so and libdl. > >> Additionally, rename it to DL_OPENED2 for clarity. > > > > What needs to be clarified? > > A DL_OPENED2 without DL_OPENED looks strange to me. > > Isn't git log enough to see what has changed? > > At now, logic of use of DL_OPENED flag lost in space. Many years ago, > it was used to mark that fact what library was opened. It destroyed by > commits in 2005-2006 years, so it is near impossible to get additional > information about it. > > Currently, we need just to know that library was opened more than > once. Sorry if DL_OPENED2 name introduces misunderstanding, I could > easily rename it to any better variant.
Than may be we should rename it to a better variant. Could you resend v2 with that fixed? thanks Waldemar _______________________________________________ devel mailing list [email protected] http://mailman.uclibc-ng.org/cgi-bin/mailman/listinfo/devel
