On Monday, 13 July 2015 at 22:03:42 UTC, Andrew Edwards wrote:
On Sunday, 12 July 2015 at 10:10:28 UTC, Jacob Carlborg wrote:
On 2015-07-12 02:29, Andrew Edwards wrote:

Note, the current packaging format is incompatible with with OSX 10.11 (El Capitan). No previous release of DMD can be installed via the dmg files available on downloads.dlang.org or the ftp site (including
dmd.2.068.0-b1).

Why? Does it require signed packages or something? Can you disable that in system preferences as usual?

Not exactly sure *why* but the resulting message is as follows:

    This package is incompatible with this
    version of OS X and may fail to install.

    Installing this package may damage your system, and
    installation may fail. To stop the program and the
    installation, click "Cancel Installation".

Clicking "Install Anyway" I get:

                  The installation failed.

      The installer encountered an error that caused the
    installation to fail. Contact the software manufacturer
                        for assistance.

I did notice that I can no longer create folders or links in the
/usr/bin || /usr/lib || /usr/share directory or any subs there.
I can however do so in /usr/local/* which is where I've installed
the contents of dmd.2.068.0-b1. All seems to work fine.

Reply via email to