On 10/14/2016 03:28 PM, Bojun Sun wrote:

Hi all,

Maybe this is a basic question but I've been searching for the solution for a long time. Thanks in advance for helping me. Here is my situation:

I'm using one laptop connection method to connect two USRP 2920 with MIMO cable. When I plug Ethernet cable into my laptop, no LED light of the Ethernet port on USRP is on.

Methods I tried:

  * removed and connected the ethernet cable again for several times
    -- didn't work
  * removed and connected the power supply cables for several times --
    didn't work
  * used command "uhd_find_devices" in Terminal to check the hardware
    connection, turned out "No UHD Devices Found"
  * tried command "ifconfig" in Terminal but it didn't show the
    ethernet connection
  * tried couple of ethernet configuration commands in Terminal --
    didn't work

Previous work I did:

  * Successfully burned N210 firmware and FPGA images into both USRPs
  * Connected to another laptop with Ubuntu 12.04 OS, it can
    successfully recognize the USRPs; however, I have to use my laptop
    to finish the project.
  * Used Ethernet cable to connect to my network, it worked
  * Tried another laptop with Ubuntu Kylin 16.04 32-bit and had same

My question is: is it an USRP problem or my OS ethernet setting up problem? if it is my OS problem, how to solve it?

My system info:

  * Using latest GNU Radio (I think, because I followed the
    installation step by using "apt-get install gnuradio")
  * UHD version: 3.010 (followed "package manager method" from:
    https://files.ettus.com/manual/page_install.html )
  * OS: Ubuntu 16.04 64-bit
  * Two USRP 2920s connected by MIMO cable

Thanks and regards,


Do *both* of your USRPs exhibit this behavior when used individually on your laptop?

Does your laptop have a 1GiGe port, or a 100BaseT port? USRPs support only 1GiGe (and 10GiGe on the X3xx series).

Discuss-gnuradio mailing list

Reply via email to