On 02/23/2018 05:51 PM, Ellie White wrote:

Hi all,


Thanks for sharing that, Marcus! I agree with Glen that it looks like a great tool, and I look forward to testing it out -- feel free to post it on the Open Source Radio Telescopes mailing list as well in case there are folks there who would like to use it, too.

I think I had done that in the past, but will do so again.


So, back to the original question -- I am still not having any luck getting my RTL-SDR dongle to work with GNURadio on Windows 10, despite the fact that the dongle works just fine with SDR# on the same computer. Is this a known issue, and if so, are there any solutions I could try? I was hoping to use GNU Radio to test out a new antenna I built soon, so if anyone has any advice about this, again I would really appreciate hearing it!


Many thanks in advance!

I'm not a Windows guy at all, so I cannot help.  Wish I could.

Can anyone here help Ellie get GR-based "stuff" going with RTL-SDR on W10? Anything to look out for?

Also, there's the ##rtlsdr IRC channel -- a pile of Windows folks on there.



Ellie

------------------------------------------------------------------------
*From:* Discuss-gnuradio <discuss-gnuradio-bounces+orionnebula42=outlook....@gnu.org> on behalf of Glen Langston <glen.i.langs...@gmail.com>
*Sent:* Friday, February 23, 2018 7:01 AM
*To:* Marcus D. Leech
*Cc:* discuss-gnuradio@gnu.org
*Subject:* Re: [Discuss-gnuradio] RTL-SDR device failed to open in flowgraph
Hi Marcus and Ellie,

Thanks again for the flow graph Marcus. It's a very impressive piece of work. If one has only one SDR, it is necessary to change the input number of channels to 1, I think(?) Then connect the 2nd channel (chan1) to the output of the source
block.   The modified .grc file works right away.

Cheers
Glen




On Thu, Feb 22, 2018 at 11:36 PM, Marcus D. Leech <mle...@ripnet.com <mailto:mle...@ripnet.com>> wrote:

    On 02/22/2018 11:13 PM, Ellie White wrote:

    Hi all,


    I am an amateur radio astronomy enthusiast and I've been using an
    RTL-SDR (R820T) USB dongle for my projects; up until now I had
    been using a Windows 8.1 laptop, but that one is on the blink
    right now so I've switched to a Windows 10 computer. I've tried
    to plug in my SDR and run the flowgraph (attached), but I keep
    getting the output below:


    Generating: 'C:\\Users\\Deana White\\Documents\\top_block.py'

    Executing: C:\Program Files\GNURadio-3.7\gr-python27\python.exe
    -u C:\Users\Deana White\Documents\top_block.py

    Win32; Microsoft Visual C++ version 14.0; Boost_106000;
    UHD_003.010.001.001-0-unknown

    gr-osmosdr c653754d (0.1.5git) gnuradio 3.7.11.1
    built-in source types: file osmosdr fcd rtl rtl_tcp uhd hackrf
    bladerf airspy redpitaya
    Using device #0 Generic RTL2832U OEM
    usb_open error -12

    FATAL: Failed to open rtlsdr device.

    Trying to fill up 1 missing channel(s) with null source(s).
    This is being done to prevent the application from crashing
    due to gnuradio bug #528.

    gr::pagesize: no info; setting pagesize = 4096


    I've run zadig for the RTL-SDR, and it works just fine with SDR#.
    Do you have any advice as to why I might be having this problem
    with the GNURadio flowgraph?


    Thanks very much! Have a great evening and take care,


    Ellie


    I hope someone can help you, Ellie.

    My approach would be to install an operating system on your
    computer.     :) :)   [That was snarkasm, just in case it wasn't
    obvious.... ]

    Once you get it working, you (and Glen et al) might want to play with:

    https://github.com/ccera-astro/spectro_radiometer
    
<https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fccera-astro%2Fspectro_radiometer&data=02%7C01%7C%7C8d9abb52f00f49e9ccf008d57ab54e01%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636549841471892336&sdata=%2BYMCsIayCiKlERZybNHs4tg0Y97HaT%2FNYxpl2cY4rYM%3D&reserved=0>

    Cheers
    Marcus



    _______________________________________________
    Discuss-gnuradio mailing list
    Discuss-gnuradio@gnu.org <mailto:Discuss-gnuradio@gnu.org>
    https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
    
<https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.gnu.org%2Fmailman%2Flistinfo%2Fdiscuss-gnuradio&data=02%7C01%7C%7C8d9abb52f00f49e9ccf008d57ab54e01%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636549841471892336&sdata=aQcm7dEORvEXcdayYQo605sDtteStNuxg9fDaKccoyQ%3D&reserved=0>



_______________________________________________
Discuss-gnuradio mailing list
Discuss-gnuradio@gnu.org
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

Reply via email to