More info (in case Heath is around):

1. I found one offending program - MS Entourage. ON startup and at intervals 
during using it, it obviously uses HTTP for something (unrelated to actually 
reading any emails) ... this will return the "Unexpected server response in 
NTLM authentication Step 2. Giving up." Could it be Entourage can do NTLM so a 
proxied NTLM request fails?

2. Certain websites will cause the same error - no idea. What I dod know is 
that certain sites (usually have .asp or .jsp page references) also cause the 

There must be a problem with the authoxy code though....because after a certain 
# of these errors (it varies), Authoxy stops responding and delivers the Fatal 
Error: unable to create shared memory


On Friday, February 04, 2005, at 11:03AM, Steve Hodson <[EMAIL PROTECTED]> 

> Steve,
>       thanks for the reply. I will try running on a different port just in 
> case. Since 3.1.1 and 3.1.2 I thought this problem was solved too but it 
> started going wrong again, which lead me to conclude:
>1. Our IT guys changed config on the server
>2. An update from Apple screwed it. I uninstalled Authoxy and re-installed it 
>and also did the repair permissions mojo etc. to no avail.
>On Friday, February 04, 2005, at 08:36AM, Steven Stratford <[EMAIL PROTECTED]> 
>>there are some people here  :)
>>I have had very little problems or lost connections with it, once Heath made
>>some changes (3.1.1. to 3.1.2).
>>Are you running Authoxy on the same port as the proxy? Our proxy is 8080, I
>>run Authoxy on 8081. In the the NTLM tab, I'm not sure how much is relevant
>>there to dropped connections, but our proxy is on the "MAIN" server and my
>>powerbook is named "SSTRATPBOOK" in the Sharing preferences, so that's what
>>I have there.
>>As far as compatible apps, I have not found any apple app to be
>>incompatible, including iPhoto, iTunes, Safari (but use FireFox and get the
>>plugin called "SwitchProxy" if you're mobile between proxy/nonproxy
>>locations!), Software Update. Most non-apple apps are compatible, even stuff
>>like Microsoft Office Application Update. I only found Skype and MaxiBidder
>>that didn't work. Of course I haven't tried everything.
>>On 2/3/05 1:06 PM, "Steve Hodson" <[EMAIL PROTECTED]> wrote:
>>> Hi,
>>>    I've been using Authoxy for some time here at work, where almost 
>>> everything
>>> is MS based including our procy server. In the past I had occasional problem
>>> with pages not being served and the web browser giving an error..I would 
>>> then
>>> have to reboot because no combination of stop/start authoxy, log in or log 
>>> out
>>> or changing locations and then back again would get the proxy to serve me
>>> pages again. Later versions of authoxy 3.11, 3.12 seemed to be better in 
>>> this
>>> regards, killing and re-spawning threads seemed to work. Now it's gone back 
>>> to
>>> the old behaviour...I can get anywhere from 5 to 30 mins working and then
>>> *boom*.
>>>  It is conceivable that our IT dept upgraded the server and there are 
>>> version
>>> issues (e.g. a timeout maybe) Has anyone else encountered this and found a
>>> possible solution?
>>> Stuck using Mac IE 5.xx right now and none of the other internet apps work
>>> without Authoxy working well.
>>> i wish Apple would build an NTLM auth module into the OS...Mac is 
>>> practically
>>> useless without Authoxy.
>>> Thanks,
>>> Steve

Reply via email to