I have not seen this issue, nor am I familiar with MobaXTerm.  But if
you're running apt-cyg, then I guess this implies it comes with a
Cygwin installation?  I am using Cygwin, and have never had an issue
like this with git in Cygwin.  I also don't understand all the answers
that invoke putty.  git on Cygwin should just work--I would make sure
that when running git it's actually the one in Cygwin.

Meanwhile, I would love it if someone would like to comment on my
proposal for redoing how the Software Carpentry Windows installer
works: https://github.com/swcarpentry/windows-installer/issues/56

The "windows installer" has always just been a Python script that
downloads some programs, unpacks them to a standard location on the
user's machine, and does a bit of configuration.  The "executable"
wrapper around it doesn't do anything differently.  This has been
causing all sorts of problems lately, as users run into download
issues, sometimes due to external server issues, and more recently due
to problems with SSL support.  The Windows installer ought to be
replaced with an "all inclusive" bundle that contains everything
needed for the workshop in a single installer that can be distributed
on USB keys and the like.

I'm also thinking of dropping use of Git-for-Windows and switching to
an all Cygwin-based install but that's a slightly different issue.

On Tue, Sep 20, 2016 at 8:07 PM, Maxime Boissonneault
<maxime.boissonnea...@calculquebec.ca> wrote:
> Hi,
> Since we've been having frequent problem using Git+Bash because of its lack
> of Nano (and people not following the installation steps to the letter), we
> attempted using MobaXTerm instead, and have them run
> apt-cyg install nano
> apt-cyg install git
> before the class. This worked great.... until we tried a "git
> pull/clone/push". For some reason, everything works, except this. I could
> not replicate on Windows 7, but both users with Windows 10 had problems, and
> my colleague could replicate it with Windows 8.
> Has anyone run into this problem and knows of a simple solution ?
> I already found this page which seems related:
> http://stackoverflow.com/questions/33240137/git-clone-pull-continually-freezing-at-store-key-in-cache
> but even if I could reproduce the problem and the solution, I don't think
> that installing putty to approve of a key is a viable solution for
> beginners...
> --
> ---------------------------------
> Maxime Boissonneault
> Analyste de calcul - Calcul Québec, Université Laval
> Président - Comité de coordination du soutien à la recherche de Calcul
> Québec
> Team lead - Research Support National Team, Compute Canada
> Instructeur Software Carpentry
> Ph. D. en physique
> _______________________________________________
> Discuss mailing list
> Discuss@lists.software-carpentry.org
> http://lists.software-carpentry.org/listinfo/discuss
Discuss mailing list

Reply via email to