On Fri, May 6, 2011 at 12:08 PM, Mateusz Harasymczuk <m...@harasymczuk.pl>wrote:

> I had an idea.
>
> To move model fields options, such as:
> - blank=BOOL
> - null=BOOL
> - auto_add=BOOL
> - auto_add_now=BOOL
> - db_index=BOOL
>
> and others boolean options to Meta class of this model.
>
> It would make model fields more readable and human friendly.
> However I am not convinced, that it would be a good idea, thou.
>
> I am just giving an discussion topic.
>
> it works for unique_together
> why not to add:
>
> unique = ('name', 'login', 'ssn')
> db_index = ('name', 'login')
> auto_add = ('signup_date', )
> auto_add_now = ('last_mod', )
> null = ('comment', 'first_name')
>
> ... and so on ...
>
> What do you think?
>
>
> --
> Matt Harasymczuk
> http://www.matt.harasymczuk.pl
>
> --
> You received this message because you are subscribed to the Google Groups
> "Django developers" group.
> To post to this group, send email to django-developers@googlegroups.com.
> To unsubscribe from this group, send email to
> django-developers+unsubscr...@googlegroups.com.
> For more options, visit this group at
> http://groups.google.com/group/django-developers?hl=en.
>

Sounds like a bad idea to me.  unique_together doesn't exist on a specific
field precisely because it isn't an option for any specific fields, it's for
a set of fields.  All the other options belond to specific fields.

Alex

-- 
"I disapprove of what you say, but I will defend to the death your right to
say it." -- Evelyn Beatrice Hall (summarizing Voltaire)
"The people's good is the highest law." -- Cicero

-- 
You received this message because you are subscribed to the Google Groups 
"Django developers" group.
To post to this group, send email to django-developers@googlegroups.com.
To unsubscribe from this group, send email to 
django-developers+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/django-developers?hl=en.

Reply via email to