Yes I'm not a fan of the *dangerously...* names either. I'm still somewhat 
wary of *trust_html* which is a *verb* and could still confuse users in a 
similar way (does the api make it trustworthy?). I think I'd prefer 
something more descriptive like *trusted_html*.

<div>{{ content|trusted_html }}</div>
vs
<div>{{ content|trust_html }}</div>

On Friday, 23 February 2018 01:07:12 UTC+11, Adam Johnson wrote:
>
> I am also in favour of a rename without deprecating the old name.
>
> I like 'trust_html' - it's still similarly short but as Tom says it 
> implies more than 'mark_safe' does.
>
> On 22 February 2018 at 08:30, Tom Forbes <t...@tomforb.es <javascript:>> 
> wrote:
>
>> What about just 'trust_html'? The dangerous part is quite context 
>> dependent (and a bit of mouth-full), but at the core you are trusting the 
>> HTML. Hopefully it follows that you should not trust html with user input 
>> that hasn't been escaped.
>>
>>
>> On 22 Feb 2018 13:10, "Anthony King" <anthon...@gmail.com <javascript:>> 
>> wrote:
>>
>> I entirely agree with renaming `mark_safe`. Though it's name is correct, 
>> it doesn't convey the gravity of what this actually does.
>> However I'm unsure on the `dangerously_trust_html` name. It wouldn't be 
>> dangerous to trust the literal "<small>Some Content</small>", for example.
>>
>> Perhaps it could be something a bit more explicit. `no_escape(string)`?
>> This assumes that most have at least heard of escaping.
>>
>>
>> On 22 February 2018 at 12:16, Josh Smeaton <josh.s...@gmail.com 
>> <javascript:>> wrote:
>>
>>> The concern isn't overusing an API. It's not understanding the proper 
>>> use case for it.
>>>
>>> "mark safe" can sound like the API is doing sanitation so it can 
>>> encourage developers to use it incorrectly. I'm fairly sure I've done this 
>>> myself.
>>>
>>> The intended meaning is "this output is **already** safe" but the name 
>>> doesn't convey that meaning clearly enough.
>>>
>>> What the proposal is designed to do is convey the "I trust this output" 
>>> meaning of the API. I'm just wary of enforcing users to change code when 
>>> they already use the API correctly.
>>>
>>> On Thursday, 22 February 2018 21:08:31 UTC+11, Florian Apolloner wrote:
>>>>
>>>> Yeah, I am also worried about the churn for no gain in my eyes. If 
>>>> users overuse mark_safe, they will overuse dangerously_trust_html too…
>>>>
>>>> On Wednesday, February 21, 2018 at 10:41:15 PM UTC+1, Josh Smeaton 
>>>> wrote:
>>>>>
>>>>> I agree that the names are misleading and we should probably provide 
>>>>> better names. I'm wary of deprecating the old names because it'll create 
>>>>> a 
>>>>> lot of churn (some of which would be the right thing to do). Maybe we 
>>>>> could 
>>>>> just alias and warn when using the old name, leaving a decision on 
>>>>> deprecation until some time in the future.
>>>>>
>>>>> On Monday, 29 January 2018 03:14:27 UTC+11, Stuart Cox wrote:
>>>>>>
>>>>>> In my experience, misuse of mark_safe() — i.e. marking stuff safe 
>>>>>> which *isn’t* actually safe (e.g. HTML from a rich text input) — is 
>>>>>> one of the biggest causes of XSS vulnerabilities in Django projects.
>>>>>>
>>>>>> The docs warn to be careful, but unfortunately I think Django devs 
>>>>>> have just got too used to mark_safe() being *the way* to insert HTML 
>>>>>> in a template. And it’s easy for something that was safe when it was 
>>>>>> authored (e.g. calling mark_safe() on a hard-coded string) to be 
>>>>>> copied / repurposed / adapted into a case which is no longer be safe 
>>>>>> (e.g. 
>>>>>> that string replaced with a user-provided value).
>>>>>>
>>>>>> Some other frameworks use scary sounding names to help reinforce that 
>>>>>> there are dangers around similar features, and that this isn’t something 
>>>>>> you should use in everyday work — e.g. React’s 
>>>>>> dangerouslySetInnerHTML.
>>>>>>
>>>>>> Relatedly, this topic 
>>>>>> <https://groups.google.com/d/msg/django-developers/c4fa2pOcHxo/EtT942WnyiAJ>
>>>>>>  suggested 
>>>>>> making it more explicit that mark_safe() refers to being safe for 
>>>>>> use in *HTML* contexts (rather than JS, CSS, SQL, etc).
>>>>>>
>>>>>> Combining the two, it would be great if Django could rename 
>>>>>> mark_safe() to dangerously_trust_html(), |safe to 
>>>>>> |dangerously_trust_html, @csrf_exempt to @dangerously_csrf_exempt, 
>>>>>> etc.
>>>>>>
>>>>>> Developers who know what they’re doing with these could then be 
>>>>>> encouraged to create suitable wrappers which handle their use case 
>>>>>> safely 
>>>>>> internally — e.g.:
>>>>>>
>>>>>> @register.filter
>>>>>> def sanitize_and_trust_html(value):
>>>>>>     # Safe because we sanitize before trusting
>>>>>>     return dangerously_trust_html(bleach.clean(value))
>>>>>>
>>>>>>
>>>>>> -- 
>>> You received this message because you are subscribed to the Google 
>>> Groups "Django developers (Contributions to Django itself)" group.
>>> To unsubscribe from this group and stop receiving emails from it, send 
>>> an email to django-develop...@googlegroups.com <javascript:>.
>>> To post to this group, send email to django-d...@googlegroups.com 
>>> <javascript:>.
>>> Visit this group at https://groups.google.com/group/django-developers.
>>> To view this discussion on the web visit 
>>> https://groups.google.com/d/msgid/django-developers/db4ac958-89e1-4286-a616-99e9854c9bbb%40googlegroups.com
>>>  
>>> <https://groups.google.com/d/msgid/django-developers/db4ac958-89e1-4286-a616-99e9854c9bbb%40googlegroups.com?utm_medium=email&utm_source=footer>
>>> .
>>>
>>> For more options, visit https://groups.google.com/d/optout.
>>>
>>
>> -- 
>> You received this message because you are subscribed to the Google Groups 
>> "Django developers (Contributions to Django itself)" group.
>> To unsubscribe from this group and stop receiving emails from it, send an 
>> email to django-develop...@googlegroups.com <javascript:>.
>> To post to this group, send email to django-d...@googlegroups.com 
>> <javascript:>.
>> Visit this group at https://groups.google.com/group/django-developers.
>> To view this discussion on the web visit 
>> https://groups.google.com/d/msgid/django-developers/CALs0z1YuC63d6aJ1VEhcnezpCg1NPJYpadcR4-fRRwGDrR4-qw%40mail.gmail.com
>>  
>> <https://groups.google.com/d/msgid/django-developers/CALs0z1YuC63d6aJ1VEhcnezpCg1NPJYpadcR4-fRRwGDrR4-qw%40mail.gmail.com?utm_medium=email&utm_source=footer>
>> .
>>
>> For more options, visit https://groups.google.com/d/optout.
>>
>> -- 
>> You received this message because you are subscribed to the Google Groups 
>> "Django developers (Contributions to Django itself)" group.
>> To unsubscribe from this group and stop receiving emails from it, send an 
>> email to django-develop...@googlegroups.com <javascript:>.
>> To post to this group, send email to django-d...@googlegroups.com 
>> <javascript:>.
>> Visit this group at https://groups.google.com/group/django-developers.
>> To view this discussion on the web visit 
>> https://groups.google.com/d/msgid/django-developers/CAFNZOJPfw9ybsHOcs%3D9nfORtEJJz9pzKvEM7bRA6BaYwHXW3pQ%40mail.gmail.com
>>  
>> <https://groups.google.com/d/msgid/django-developers/CAFNZOJPfw9ybsHOcs%3D9nfORtEJJz9pzKvEM7bRA6BaYwHXW3pQ%40mail.gmail.com?utm_medium=email&utm_source=footer>
>> .
>>
>> For more options, visit https://groups.google.com/d/optout.
>>
>
>
>
> -- 
> Adam
>

-- 
You received this message because you are subscribed to the Google Groups 
"Django developers  (Contributions to Django itself)" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to django-developers+unsubscr...@googlegroups.com.
To post to this group, send email to django-developers@googlegroups.com.
Visit this group at https://groups.google.com/group/django-developers.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-developers/67822239-8e38-4723-9475-bd64cf81db50%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to