#24335: DateRange and friends require psycopg2 >= 2.5
-------------------------------------+-------------------------------------
Reporter: claudep | Owner: ovangle
Type: | Status: assigned
Cleanup/optimization |
Component: contrib.postgres | Version: 1.8alpha1
Severity: Normal | Resolution:
Keywords: 1.8-beta | Triage Stage: Accepted
Has patch: 0 | Needs documentation: 0
Needs tests: 0 | Patch needs improvement: 0
Easy pickings: 0 | UI/UX: 0
-------------------------------------+-------------------------------------
Comment (by ovangle):
I've submitted a patch https://github.com/django/django/pull/4131 which
conditionally defines the classes if an `ImportError` is raised when
importing psycopg2.extras.Range.
I'm happy changing it to require `psycopg2>=2.5`, but obviously since this
is my first contribution a suggestion like that was not my call to make
and the bug as described had been accepted, so I implemented it directly
as stated. Personally, my opinion on these matters is usually "continue
support for the last two major versions of a package".
--
Ticket URL: <https://code.djangoproject.com/ticket/24335#comment:4>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.
--
You received this message because you are subscribed to the Google Groups
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit
https://groups.google.com/d/msgid/django-updates/065.95a8145558c1a847aa15beabeaf0f146%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.