#24335: DateRange and friends require psycopg2 >= 2.5
-------------------------------------+-------------------------------------
     Reporter:  claudep              |                    Owner:  ovangle
         Type:                       |                   Status:  assigned
  Cleanup/optimization               |
    Component:  contrib.postgres     |                  Version:  1.8alpha1
     Severity:  Normal               |               Resolution:
     Keywords:  1.8-beta             |             Triage Stage:  Accepted
    Has patch:  0                    |      Needs documentation:  0
  Needs tests:  0                    |  Patch needs improvement:  0
Easy pickings:  0                    |                    UI/UX:  0
-------------------------------------+-------------------------------------

Comment (by ovangle):

 I'll defer completing this until I get some consensus about minimum
 supported versions.

 It seems that `2.5` is an OK minimum for `django.contrib.postgres`, but
 `2.4.5` added support for Inet arrays to the `Inet` object, so that's the
 current minimum supported version for `db.backends` without a change to
 the current code (at least a more informative error than the current one
 about new_array_type being unavailable).

--
Ticket URL: <https://code.djangoproject.com/ticket/24335#comment:11>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/065.3210540f4ed9a6ee335805d7f4c351fa%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to