On 160920-00:52+0200, Miroslav Rovis wrote:
> Thanks for more interest! Good news very likely coming! (And I'm happy I
> can stay a little bit longer ;-)  )
> 
> On 160919-11:13-1000, Joel Roth wrote:
> > On Mon, Sep 19, 2016 at 09:51:54PM +0200, Miroslav Rovis wrote:
> > > On 160919-08:11-1000, Joel Roth wrote:
> > > > Miroslav Rovis wrote:
> > > > > https://git.devuan.org/dev1fanboy/Upgrade-Install-Devuan/wikis/Devuan-without-dbus
> > > > 
> > > > apt-get remove dbus doesn't help with de**an packaged apps dependent on
> > > > dbus such as inkscape and liferea.
> > > >
> > > (unable to make this experiment quicker and simpler)
> > > I'm attempting:
> > > # emerge -ptuDN inkscape
> > > 
...
> > > !!! All ebuilds that could satisfy ">=app-text/poppler-0.26.0:=[cairo]" 
> > > have been masked.
...
> > > - app-text/poppler-0.47.0::gentoo (masked by: package.mask)
...
> > > (dependency required by "media-gfx/inkscape-0.91-r3::gentoo" [ebuild])
...
> > > And yes, poppler pulls in dbus (if I tried to unmask it).
> > 
> > Which poppler packages need attention?
> 
> Hey I was wrong! I can (doing it right now), I'm almost certain that I
> can install Inkscape in my Gentoo.
> 
> And it's the good ole FOSS/GNU/Linix as Devuan is, true-unix! So it's
> probably just a little help from our devs here at Devuan and Devuaners
> can have Inkscape in sans-dbus machines!
> 
> I've prepared a text about it, but it's maybe a few hours on my 4core
> AMD 965 old CPU the various installs of new and reinstalls of old
> packages in new ways... So allow me to report after I complete the
> installation.
>

The report that I promised. Allow me not to have to rephrase what I had
prepared before sending my post immediately previous to this post.

The reinstalls/installs are not done, there's likely some two hours for only
libreoffice to compile, and that one is last to compile and install, but...

[But] I have installed Inkscape, dear colleage!

# inkscape -V
Inkscape 0.91 r13725 (Sep 20 2016)
#

So, the previously written text follows below.

Wait a minute, maybe inkscape can be installed. I do have poppler installed in
my machines:

# equery l poppler
 * Searching for poppler ...
[I--] [??] app-text/poppler-0.32.0:0/51
g0n ~ 
#

The thing is, Inkscape only needs a newer one.

After I commented out what hopefully is not necessary (and I don't remember
why it was there):

> grep poppler /etc/portage/package.mask
#>=app-text/poppler-0.34.0

(which said to preclude versions greater than 0.34.0)

And allowed emerge to change my /etc/portage/package.use which previously had
this entry:

app-text/poppler qt4

and I allowed the emerge to change it along these diff lines:

+# required by media-gfx/inkscape-0.91-r3::gentoo
+# required by inkscape (argument)
+>=app-text/poppler-0.47.0 cairo
lines 1-10/10 (END)

All that is now in effect equivalent to this setup:

>=app-text/poppler-0.47.0 qt4 cairo

I believe.

Let me see what happens. I'd be excited to be able to install Inkscape, and
then likely it can be installed on a sans-dbus Devuan as well.

( I see now I also need to install cairo... Hmmmhh... )

Let me see:

# emerge -tuDNf inkscape


These are the packages that would be fetched, in order:

Calculating dependencies                                  ... done!
[ebuild  N     ] media-gfx/inkscape-0.91-r3::gentoo  USE="cdr imagemagick jpeg 
nls openmp -dbus -dia -exif -gnome -inkjar -latex -lcms -postscript -spell 
-static-libs -visio -wpg" PYTHON_TARGETS="python2_7" 25,253 KiB
[ebuild  N     ]  media-gfx/uniconvertor-2.0_pre379-r1::gentoo  
PYTHON_TARGETS="python2_7" 1,802 KiB
[ebuild  N     ]  dev-cpp/gtkmm-2.24.4-r3:2.4::gentoo  USE="-doc -examples 
{-test}" ABI_X86="(64) -32 (-x32)" 10,022 KiB
[ebuild  N     ]   dev-cpp/pangomm-2.40.0:1.4::gentoo  USE="-doc" ABI_X86="(64) 
-32 (-x32)" 777 KiB
[ebuild     U  ]  app-text/poppler-0.47.0:0/63::gentoo [0.32.0:0/51::gentoo] 
USE="cairo* cxx jpeg jpeg2k lcms png qt4 tiff utils (-cairo-qt) -cjk -curl 
-debug -doc -introspection -nss% -qt5" 1,643 KiB
[ebuild  N     ]  dev-cpp/cairomm-1.12.0-r1::gentoo  USE="X svg (-aqua) -doc" 
ABI_X86="(64) -32 (-x32)" 772 KiB
[ebuild  N     ]  sci-libs/gsl-2.1:0/19::gentoo  USE="-cblas-external 
-static-libs" 3,738 KiB
[ebuild  N     ]   app-eselect/eselect-cblas-0.1::gentoo  0 KiB
[nomerge       ] media-gfx/uniconvertor-2.0_pre379-r1::gentoo  
PYTHON_TARGETS="python2_7" 
[ebuild  N     ]  dev-python/pillow-3.1.1::gentoo  USE="jpeg jpeg2k tiff 
truetype zlib -doc -examples -lcms {-test} -tk -webp" PYTHON_TARGETS="python2_7 
python3_4 -pypy (-python3_3) -python3_5" 10,110 KiB
[nomerge       ] dev-cpp/gtkmm-2.24.4-r3:2.4::gentoo  USE="-doc -examples 
{-test}" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ]  dev-cpp/atkmm-2.24.2::gentoo  USE="-doc" ABI_X86="(64) -32 
(-x32)" 830 KiB

Total: 10 packages (1 upgrade, 9 new), Size of downloads: 54,944 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/poppler:0

  (app-text/poppler-0.47.0:0/63::gentoo, ebuild scheduled for merge) pulled in 
by
    >=app-text/poppler-0.26.0:=[cairo] required by 
(media-gfx/inkscape-0.91-r3:0/0::gentoo, ebuild scheduled for merge)
                                ^^^^^                                           
                                                                           

  (app-text/poppler-0.32.0:0/51::gentoo, installed) pulled in by
    app-text/poppler:0/51=[cxx] required by 
(app-office/libreoffice-5.1.4.2:0/0::gentoo, installed)
                    ^^^^^^                                                      
                                                       
    <app-text/poppler-0.35.0:0/51=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required 
by (net-print/cups-filters-1.0.71:0/0::gentoo, installed)
    ^                 ^^^^^^^^^^^^                                              
                                                                                
                                                   
    (and 1 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Would you like to fetch the source files for these packages? [Yes/No] 

I'll probably be able to install Inkscape, bro! Here's the entire emerge 
output. It's just the minor issue left to solve:


# emerge -tuDN inkscape

These are the packages that would be merged, in reverse order:

Calculating dependencies                     ... done!      
[ebuild  N     ] media-gfx/inkscape-0.91-r3::gentoo  USE="cdr imagemagick jpeg 
nls openmp -dbus -dia -exif -gnome -inkjar -latex -lcms -postscript -spell 
-static-libs -visio -wpg" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  N     ]  media-gfx/uniconvertor-2.0_pre379-r1::gentoo  
PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  N     ]  dev-cpp/gtkmm-2.24.4-r3:2.4::gentoo  USE="-doc -examples 
{-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ]   dev-cpp/pangomm-2.40.0:1.4::gentoo  USE="-doc" ABI_X86="(64) 
-32 (-x32)" 0 KiB
[ebuild     U  ]  app-text/poppler-0.47.0:0/63::gentoo [0.32.0:0/51::gentoo] 
USE="cairo* cxx jpeg jpeg2k lcms png qt4 tiff utils (-cairo-qt) -cjk -curl 
-debug -doc -introspection -nss% -qt5" 0 KiB
[ebuild  N     ]  dev-cpp/cairomm-1.12.0-r1::gentoo  USE="X svg (-aqua) -doc" 
ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ]  sci-libs/gsl-2.1:0/19::gentoo  USE="-cblas-external 
-static-libs" 0 KiB
[ebuild  N     ]   app-eselect/eselect-cblas-0.1::gentoo  0 KiB
[nomerge       ] media-gfx/uniconvertor-2.0_pre379-r1::gentoo  
PYTHON_TARGETS="python2_7" 
[ebuild  N     ]  dev-python/pillow-3.1.1::gentoo  USE="jpeg jpeg2k tiff 
truetype zlib -doc -examples -lcms {-test} -tk -webp" PYTHON_TARGETS="python2_7 
python3_4 -pypy (-python3_3) -python3_5" 0 KiB
[nomerge       ] dev-cpp/gtkmm-2.24.4-r3:2.4::gentoo  USE="-doc -examples 
{-test}" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ]  dev-cpp/atkmm-2.24.2::gentoo  USE="-doc" ABI_X86="(64) -32 
(-x32)" 0 KiB

Total: 10 packages (1 upgrade, 9 new), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/poppler:0

  (app-text/poppler-0.47.0:0/63::gentoo, ebuild scheduled for merge) pulled in 
by
    >=app-text/poppler-0.26.0:=[cairo] required by 
(media-gfx/inkscape-0.91-r3:0/0::gentoo, ebuild scheduled for merge)
                                ^^^^^                                           
                                                                           

  (app-text/poppler-0.32.0:0/51::gentoo, installed) pulled in by
    <app-text/poppler-0.35.0:0/51=[cxx,jpeg,lcms,tiff,xpdf-headers(+)] required 
by (net-print/cups-filters-1.0.71:0/0::gentoo, installed)
    ^                 ^^^^^^^^^^^^                                              
                                                                                
                                                   
    app-text/poppler:0/51=[cxx] required by 
(app-office/libreoffice-5.1.4.2:0/0::gentoo, installed)
                    ^^^^^^                                                      
                                                       
    (and 1 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

g0n ~ # 


Or will I be able to install Inkscape? Has Cups gone dbus-dependent? Because
that seems to be the issue:

This it is like currently:
# 2 ln were temporarily masked. Else wouldn't have 'emerge world'.
>=net-print/cups-filters-1.0.73
>=net-print/cups-2.0.4
#>=app-text/poppler-0.34.0

Turning it to all commented out, and trying now...

Have a look! This means you can very like have sans-dbus Inkscape in your
Devuan too!

# emerge -tuDN inkscape

These are the packages that would be merged, in reverse order:

Calculating dependencies                    ... done!                 
[ebuild  rR    ] app-office/libreoffice-5.1.4.2::gentoo  USE="branding cups
gstreamer gtk (-aqua) -bluetooth -coinmp -collada -dbus -debug -eds
(-firebird) -gltf -gnome -google -gtk3 -java -jemalloc -kde -libressl -mysql
-odk -postgres -quickstarter (-telepathy) {-test} -vlc"
LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript
-wiki-publisher" PYTHON_SINGLE_TARGET="python3_4 -python2_7 -python3_5"
PYTHON_TARGETS="python2_7 python3_4 -python3_5" 0 KiB
[ebuild  rR    ] app-text/texlive-core-2015::gentoo  USE="X luajittex xetex
-cjk -doc -source -tk" 1,057 KiB
[ebuild  N     ] media-gfx/inkscape-0.91-r3::gentoo  USE="cdr imagemagick jpeg
nls openmp -dbus -dia -exif -gnome -inkjar -latex -lcms -postscript -spell
-static-libs -visio -wpg" PYTHON_TARGETS="python2_7" 0 KiB
[nomerge       ] media-gfx/imagemagick-6.9.5.5:0/6.9.5.5::gentoo  USE="X bzip2
corefonts cxx djvu fftw fontconfig fpx graphviz hdri jbig jpeg jpeg2k lcms lqr
openexr openmp pango perl png postscript svg tiff truetype webp wmf xml zlib
-autotrace -lzma -opencl -q32 -q64 -q8 -raw -static-libs {-test}" 
[nomerge       ]  media-libs/libwmf-0.2.8.4-r6::gentoo  USE="X -debug -doc
-expat -xml" 
[nomerge       ]   app-text/ghostscript-gpl-9.19::gentoo  USE="X cups tiff
-dbus -djvu -gtk -idn -static-libs" L10N="-de -ja -ko -zh-CN -zh-TW" 
[nomerge       ]    net-print/cups-2.1.4::gentoo [2.0.3::gentoo] USE="X acl
ssl threads -dbus -debug -java -kerberos -lprng-compat -pam -python (-selinux)
-static-libs -systemd -usb -xinetd -zeroconf" ABI_X86="(64) -32 (-x32)"
LINGUAS="ca cs de es fr it ja ru" PYTHON_TARGETS="python2_7" 
[ebuild     U  ]     net-print/cups-filters-1.11.2::gentoo [1.0.71::gentoo]
USE="foomatic jpeg png postscript%* tiff -dbus -ldap% -perl -static-libs
-zeroconf" 1,372 KiB
[nomerge       ] media-gfx/inkscape-0.91-r3::gentoo  USE="cdr imagemagick jpeg
nls openmp -dbus -dia -exif -gnome -inkjar -latex -lcms -postscript -spell
-static-libs -visio -wpg" PYTHON_TARGETS="python2_7" 
[ebuild  N     ]  media-gfx/uniconvertor-2.0_pre379-r1::gentoo
PYTHON_TARGETS="python2_7" 0 KiB
[nomerge       ] app-office/libreoffice-5.1.4.2::gentoo  USE="branding cups
gstreamer gtk (-aqua) -bluetooth -coinmp -collada -dbus -debug -eds
(-firebird) -gltf -gnome -google -gtk3 -java -jemalloc -kde -libressl -mysql
-odk -postgres -quickstarter (-telepathy) {-test} -vlc"
LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript
-wiki-publisher" PYTHON_SINGLE_TARGET="python3_4 -python2_7 -python3_5"
PYTHON_TARGETS="python2_7 python3_4 -python3_5" 
[ebuild     U  ]  net-print/cups-2.1.4::gentoo [2.0.3::gentoo] USE="X acl ssl
threads -dbus -debug -java -kerberos -lprng-compat -pam -python (-selinux)
-static-libs -systemd -usb -xinetd -zeroconf" ABI_X86="(64) -32 (-x32)"
LINGUAS="ca cs de es fr it ja ru" PYTHON_TARGETS="python2_7" 9,349 KiB
[nomerge       ] media-gfx/inkscape-0.91-r3::gentoo  USE="cdr imagemagick jpeg
nls openmp -dbus -dia -exif -gnome -inkjar -latex -lcms -postscript -spell
-static-libs -visio -wpg" PYTHON_TARGETS="python2_7" 
[ebuild  N     ]  dev-cpp/gtkmm-2.24.4-r3:2.4::gentoo  USE="-doc -examples
{-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ]   dev-cpp/pangomm-2.40.0:1.4::gentoo  USE="-doc"
ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ]    dev-cpp/cairomm-1.12.0-r1::gentoo  USE="X svg (-aqua)
-doc" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  r  U  ]  app-text/poppler-0.47.0:0/63::gentoo [0.32.0:0/51::gentoo]
USE="cairo* cxx jpeg jpeg2k lcms png qt4 tiff utils (-cairo-qt) -cjk -curl
-debug -doc -introspection -nss% -qt5" 0 KiB
[ebuild  N     ]  sci-libs/gsl-2.1:0/19::gentoo  USE="-cblas-external
-static-libs" 0 KiB
[ebuild  N     ]   app-eselect/eselect-cblas-0.1::gentoo  0 KiB
[nomerge       ] media-gfx/uniconvertor-2.0_pre379-r1::gentoo
PYTHON_TARGETS="python2_7" 
[ebuild  N     ]  dev-python/pillow-3.1.1::gentoo  USE="jpeg jpeg2k tiff
truetype zlib -doc -examples -lcms {-test} -tk -webp"
PYTHON_TARGETS="python2_7 python3_4 -pypy (-python3_3) -python3_5" 0 KiB
[nomerge       ] dev-cpp/gtkmm-2.24.4-r3:2.4::gentoo  USE="-doc -examples
{-test}" ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ]  dev-cpp/atkmm-2.24.2::gentoo  USE="-doc" ABI_X86="(64) -32
(-x32)" 0 KiB
[nomerge       ] net-print/cups-filters-1.11.2::gentoo [1.0.71::gentoo]
USE="foomatic jpeg png postscript%* tiff -dbus -ldap% -perl -static-libs
-zeroconf" 
[ebuild  N     ]  dev-util/gdbus-codegen-2.48.1::gentoo
PYTHON_TARGETS="python2_7 python3_4 -python3_5" 0 KiB
[ebuild     U  ]  app-text/qpdf-6.0.0:0/17::gentoo [5.1.3:0/13::gentoo]
USE="-doc -examples -static-libs {-test}" 8,150 KiB

Total: 16 packages (4 upgrades, 10 new, 2 reinstalls), Size of downloads:
19,927 KiB

The following packages are causing rebuilds:

  (app-text/poppler-0.47.0:0/63::gentoo, ebuild scheduled for merge) causes 
rebuilds for:
    (net-print/cups-filters-1.11.2:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/inkscape-0.91-r3:0/0::gentoo, ebuild scheduled for merge)
    (app-office/libreoffice-5.1.4.2:0/0::gentoo, ebuild scheduled for merge)
    (app-text/texlive-core-2015:0/0::gentoo, ebuild scheduled for merge)

Would you like to merge these packages? [Yes/No] 

And here I went installing. (and if I don't report issues with
installing any of the above that are being installed, than it went all
fine)

Again, this means that the trail has been blazed and that it can be done in
Devuan as well. If only I were really a developer ;-) ...

Regards!

-- 
Miroslav Rovis
Zagreb, Croatia
http://www.CroatiaFidelis.hr

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng

Reply via email to