hi all,

there is a problem in using Devuan in Vagrant, due to the fact Vagrant
does not recognise Devuan as a Debian, because nor lsb_release or
/etc/os-release carry a string that is matched by the checks.

This is the directory holding Vagrant's plugins doing the check
beware Vagrant is written in Ruby.

It can be pretty easy to duplicate the Debian plugin, which still
carries the procedures to operate with sysvlinux (not sure for how
long) and remove the systemd'isms and file a PR to have a Devuan
plugin in Vagrant.

Any volunteers? I thought of asking here before being damned looking
for the time to do it myself... ;^)


Dng mailing list

Reply via email to