Most modern network capable printers have a web interface these days, just find the IP address, stick that into a browser and you should get a status page, you should also be able to get to a configuration pages for the device. Like Terry and Peter I always assign static IP 's I learnt long ago after a session of hunt the device across a lan.

Many years ago support company spent an entire day trying to connect a HP Inkjet printer to a Unix system including a multiplexer. Eventually the boss came and tried and realised that the inkjet would never work as it was a Winprinter (where half the firmware was delivered as windows software drivers). It will never work the boss shouted in frustration of the wasted day, he he had no answer as to why when it was first setup earlier in the day it printed a test page and two work related pages, then just stopped.


Tim H

On 14/01/2022 16:58, PeterMerchant wrote:
Can't help with the scanning, but I have a brother wireless printer HL-1210W series  and like Terry have it programmed to a fixed IP address, and never have any trouble with it.

The manual refers to saving the scanned item to a folder, but is this folder in a storage medium in the scanner or on your computer? As Terry suggests, can you browse to the printers web page and find any 'stored' scans?


On 14/01/2022 15:38, Terry Coles wrote:

One or two thoughts which may or may not be helpful.

On Friday, 14 January 2022 15:24:31 GMT JD wrote:
I have a Brother laser printer - DCP1612W.  Yesterday I scanned a couple
of photos and saved them as jpg's.  About a half-hour later I got only
an error message each time I ran xsane, and that is still the case.
Printing continues to work as normal.
Caveat:  I've never used any kind of Brother Device; I've always bought HP.

Ubuntu 20.04.3
The error message is: "Failed to open device 'brother4:net;dev0':
Invalid argument."
No thoughts on this.
It's configured to connect via WLAN. The IP address appears in the
router list occasionally but usually not.
For various reasons, I've always configured utility devices on my home network with a static IP Address.  On my HP, I can then browse to it's Home Page to
check its status.  Does you Brother have a web page?

After: scanimage -L
I get "device `brother4:net1;dev0' is a Brother *DCP1610W DCP1612W", so
the correct model is known about.
What did I do in the fateful 30 mins yesterday afternoon!?

I have no idea really, but since it is not always visible in your Router
settings, I would suspect that the WiFi connection isn't all it could be.

 Next meeting: Online, Jitsi, Tuesday, 2022-02-01 20:00
 Check to whom you are replying
 Meetings, mailing list, IRC, ...
 New thread, don't hijack:

Reply via email to