On 4/14/20 3:01 PM, Greg Kroah-Hartman wrote:
On Tue, Apr 14, 2020 at 02:42:58PM +0200, Emanuele Giuseppe Esposito wrote:
It is a common special case for new_inode to initialize the
time to the current time and the inode to get_next_ino().
Introduce a core function that does it and use it throughout
Linux.

Shouldn't this just be called new_inode_current_time()?

How is anyone going to remember what simple_new_inode() does to the
inode structure?

I noticed that most functions in libfs.c are called "simple_*" when they do the right thing for the majority of simple use cases (e.g., simple_symlink_inode_operations or simple_dir_operations). I can certainly rename the function.

Thank you for all the feedback, I will incorporate it and send a new patch series soon.


Emanuele

--- a/fs/libfs.c
+++ b/fs/libfs.c
@@ -595,6 +595,18 @@ int simple_write_end(struct file *file, struct 
address_space *mapping,
  }
  EXPORT_SYMBOL(simple_write_end);
+struct inode *simple_new_inode(struct super_block *sb)
+{
+       struct inode *inode = new_inode(sb);
+       if (inode) {
+               inode->i_ino = get_next_ino();
+               inode->i_atime = inode->i_mtime =
+                       inode->i_ctime = current_time(inode);
+       }
+       return inode;
+}
+EXPORT_SYMBOL(simple_new_inode);

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Reply via email to