Thank you, Kim. The reference was most helpful, and I repeated all the 
steps I had done, but more carefully. In particular I decided not to try 
the full source distribution this time around. I got almost to the end of 
the instructions without a problem, but then mistakenly ran maven not as 
dspace but as ec2-user, generating the installer directories with the wrong 
owner. I tried to fix this by playing with file ownership, and eventually 
did  "su dspace" and ran "ant frsh_install"... kind of all mixed up but it 
*seems* to have got to the end of the process OK. So I copied all the 
applications from [dspace]/webapps into Tomcat's webapps directory... 
restarted the Tomcat8 service... ... sent my browser to the 
"http://tomcat-url:8080/jspui ... and then waited and waited and waited and 
waited, patiently assuming the sorry little freebie AWS server was laboring 
as hard as it could to compile everything on this its first exertion... 
until finally... it just spun forever and ever, no "finally" actually. 
After 2 hours it was still spinning its wheels so I killed the browser and 
went outside to shovel snow...
Is there some way to know why it returned neither the requested page nor an 
error status?

On Tuesday, March 13, 2018 at 12:06:05 AM UTC-4, Alan Z wrote:
> I am having troubles getting started due to my not understanding some 
> basics about Tomcat and DSpace configuration.
> (This is with AWS "AMI" virtual with Tomcat 8, Postgresql 9.6, and DSpace 
> 6.2.) All pieces seem installed correctly, but for the life of me I cannot 
> get Tomcat to serve out the DSpace jspui index.jsp page. 
> In the Dspace conf.cfg I have the following values:
> dspace.dir = /home/ec2-user/dspace-6.2-src-release/dspace
> dspace.hostname =
> dspace.baseUrl =
> I commented out the line
> #dspace.url = ${dspace.baseUrl}/${dspace.ui}
> because in the Tomcat server.xml I have NOT changed the <Host> element. 
> Rather I copied all the files and folders from 
> /home/ec2-user/dspace-6.2-src-release/dspace/webapps
> to the Tomcat webapps folder. 
> Shoudn't this be enough to make possible browsers addressing
> to get the index.jsp file under jspui ? 
> I would be happy to edit the <Host> element to set the appBase to the 
> DSpace installation's webapps folder, except that my efforts to do all 
> failed. I tried various combinations such as 
> <Host name="""  
> appBase="/home/ec2-user/dspace-6.2-src-release/dspace/webapps" 
> and also
> <Host name="localhost"  
> appBase="/home/ec2-user/dspace-6.2-src-release/dspace/webapps" 
> BUT finally the only way I could get even the default Tomcat page to 
> display was to revert back to 
> <Host name="localhost"  appBase="webapps"
> That's when I thought I would just copy all the DSpace apps into the 
> default Tomcat webapps directory.
> I apologize for the newbie nature of the above. A gently hint would be 
> most appreciated!
> A

You received this message because you are subscribed to the Google Groups 
"DSpace Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
Visit this group at
For more options, visit

Reply via email to