Hi Alan,

I think we're at the point now of checking log files to see what Tomcat is 
doing, what DSpace is doing, etc.
Can I check that Tomcat knows where to find your webapps? That is, you've 
either copied webapps like 'jspui' into your Tomcat default webapp base, or 
symlink'd them in rather than copied, or configured Tomcat to look in 
${dspace}/webapps for your webapp base for the "tomcat-url:8080" context?

If your Tomcat logs (probably somewhere like /var/log/tomcat/....) show 
hardly any information and just log 'not found' errors for the requests to 
/jspui, I'd say that it doesn't know that webapp even exists -- we'll have 
to tell it where it is 
(https://tomcat.apache.org/tomcat-8.0-doc/config/context.html) or do 
something like a symlink (eg. let's say your DSpace dir is /dspace and your 
tomcat webapps dir is /usr/share/tomcat8/webapps,  then we'd do 'ln -s 
/dspace/webapps/jspui /usr/share/tomcat8/webapps/jspui' (as the DSpace / 
tomcat user)

Which reminds me, make sure the 'dspace' user is also the user that 
owns+runs tomcat8. This can be a bit of a common pitfall... I typically 
just use the default tomcat user (eg tomcat or tomcat8) as my "dspace" user 
and don't worry about making a new specially named account, that just adds 
confusion, forces me to reconfigure tomcat8 to start up as a different 
user, etc...

If Tomcat can find jspui but is having an error, you might see some 
exceptions when it tries to load the applications or kernel, and you might 
see some errors in the logs in /dspace/logs/ as well.
(feel free to paste them here if you do)



On Wednesday, March 14, 2018 at 2:56:17 PM UTC+13, Alan Z wrote:
> Thank you, Kim. The reference was most helpful, and I repeated all the 
> steps I had done, but more carefully. In particular I decided not to try 
> the full source distribution this time around. I got almost to the end of 
> the instructions without a problem, but then mistakenly ran maven not as 
> dspace but as ec2-user, generating the installer directories with the wrong 
> owner. I tried to fix this by playing with file ownership, and eventually 
> did  "su dspace" and ran "ant frsh_install"... kind of all mixed up but it 
> *seems* to have got to the end of the process OK. So I copied all the 
> applications from [dspace]/webapps into Tomcat's webapps directory... 
> restarted the Tomcat8 service... ... sent my browser to the "
> http://tomcat-url:8080/jspui ... and then waited and waited and waited 
> and waited, patiently assuming the sorry little freebie AWS server was 
> laboring as hard as it could to compile everything on this its first 
> exertion... until finally... it just spun forever and ever, no "finally" 
> actually. After 2 hours it was still spinning its wheels so I killed the 
> browser and went outside to shovel snow...
> Is there some way to know why it returned neither the requested page nor 
> an error status?
> A
> On Tuesday, March 13, 2018 at 12:06:05 AM UTC-4, Alan Z wrote:
>> I am having troubles getting started due to my not understanding some 
>> basics about Tomcat and DSpace configuration.
>> (This is with AWS "AMI" virtual with Tomcat 8, Postgresql 9.6, and DSpace 
>> 6.2.) All pieces seem installed correctly, but for the life of me I cannot 
>> get Tomcat to serve out the DSpace jspui index.jsp page. 
>> In the Dspace conf.cfg I have the following values:
>> dspace.dir = /home/ec2-user/dspace-6.2-src-release/dspace
>> dspace.hostname = states.xxxxx.net
>> dspace.baseUrl = http://states.xxxxx.net:8080
>> I commented out the line
>> #dspace.url = ${dspace.baseUrl}/${dspace.ui}
>> because in the Tomcat server.xml I have NOT changed the <Host> element. 
>> Rather I copied all the files and folders from 
>> /home/ec2-user/dspace-6.2-src-release/dspace/webapps
>> to the Tomcat webapps folder. 
>> Shoudn't this be enough to make possible browsers addressing
>> http://states.xxxxx.net:8080/jspui
>> to get the index.jsp file under jspui ? 
>> I would be happy to edit the <Host> element to set the appBase to the 
>> DSpace installation's webapps folder, except that my efforts to do all 
>> failed. I tried various combinations such as 
>> <Host name="states.xxxxx.net""  
>> appBase="/home/ec2-user/dspace-6.2-src-release/dspace/webapps" 
>> and also
>> <Host name="localhost"  
>> appBase="/home/ec2-user/dspace-6.2-src-release/dspace/webapps" 
>> BUT finally the only way I could get even the default Tomcat page to 
>> display was to revert back to 
>> <Host name="localhost"  appBase="webapps"
>> That's when I thought I would just copy all the DSpace apps into the 
>> default Tomcat webapps directory.
>> I apologize for the newbie nature of the above. A gently hint would be 
>> most appreciated!
>> A

You received this message because you are subscribed to the Google Groups 
"DSpace Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to dspace-community+unsubscr...@googlegroups.com.
To post to this group, send email to dspace-community@googlegroups.com.
Visit this group at https://groups.google.com/group/dspace-community.
For more options, visit https://groups.google.com/d/optout.

Reply via email to