On 19/09/2017 13:43, Hao Wu wrote:
>    NewValue = 0;
>    for (Index = 0; Index < 32; Index++) {
> -    if ((Value & (1 << Index)) != 0) {
> -      NewValue = NewValue | (1 << (31 - Index));
> +    if ((Value & (((UINT32)1) << Index)) != 0) {
> +      NewValue = NewValue | (((UINT32)1) << (31 - Index));
>      }


Why not just "1u" instead of the cast?

Paolo
_______________________________________________
edk2-devel mailing list
[email protected]
https://lists.01.org/mailman/listinfo/edk2-devel

Reply via email to