If you attempt to use the latest version of Vagrant, Vagrant 1.8.5, you
will likely see the following error when running "vagrant up":

Vagrant attempted to execute the capability 'change_host_name'
on the detect guest OS 'linux', but the guest doesn't
support that capability. This capability is required for your
configuration of Vagrant. Please either reconfigure Vagrant to
avoid this capability or fix the issue by creating the capability.


There is a simple fix.  You need to patch a Vagrant plugin.  Follow the
steps in the answer to this Stackoverflow post
<http://stackoverflow.com/questions/38636023/vagrant-not-supported-the-capability-change-host-name>.
Note that this issue should be patched in Vagrant 1.8.6+.

The above is also documented in Confluence under Troubleshooting Vagrant
<https://openedx.atlassian.net/wiki/display/OpenOPS/Troubleshooting+Vagrant>
.

-- 

*Robert Raposa*

edX | Software Architect  | rrap...@edx.org

141 Portland Street, 9th floor

Cambridge, MA 02139
http://www.edx.org <http://www.edxonline.org/>

[image:
http://www.e-learn.nl/media/blogs/e-learn/edX_Logo_Col_RGB_FINAL.jpg?mtime=1336074566]

-- 
You received this message because you are subscribed to the Google Groups 
"General Open edX discussion" group.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/edx-code/CAKZ_z5kENGvN03j2NXCpWTByLt9VbmWK86s6897NVjRQOFz3Rw%40mail.gmail.com.

Reply via email to