Hi there,

I tried elinks (0.11.6) on my laptop and loved it. Well done!

Next I went to install it on my main desktop, which is a Sun Blade 1000
(64 bit, big endian). I run OpenBSD, and used the  package in our ports
tree (just like I did on my laptop), however it simply does not work as
a web browser atall on the sparc64 architecture (but it works well on

First of all, it warns me of a deprecated config file, even though there
is not one. Every time. Even if you blast away ~/.elinks and try again.

The next problem is, if you change any preferences, they do not appear
to be saved. This is likely to be related to the first problem.

You also can not browse at all. You can't open a url. If you press 'g'
and type a URL and hit enter, the dialog dissappears and nothing
happens. On my i386, this would usually browse to that URL.

I asked another OpenBSD user to try elinks on his sparc64 and he
experienced the same problems.

Next I built the port on i386 and sparc64 and diffed the build output,
finding no obscure compiler warnings.

Next I built the pre-release (0.12pre5) in /tmp and experienced the

Next I built the nightly snapshot (-current-0.13), again prefixed in
/tmp and experienced the same again.

So basically, elinks is broken in many ways on sparc64. Are any of the
elinks developers interested in helping me pinpoint and eliminate these
defects? I would love to use this app on my sparc box.



Best Regards

Edd Barrett
(Freelance software developer / technical writer / open-source developer)

elinks-dev mailing list

Reply via email to