I tried upgrading from 2.7.4 to 2.7.7 (debian wheezy, apt-get) but when
I fire linuxcnc up I get a popup error message:

>G-Code error in axis.ngc
>Near line 12 of /usr/share/axis/images/axis.ngc:
>Bad character 'z' used

If I click 'OK' linuxcnc loads but the initial X & Y show as 4.23e+289
and 2.95e+240 and axis.ngc is not showing in the display.

I then tried 2.7.5 and get the same thing.  Downgrade to 2.7.4 and
everything's back to normal.

axis.ngc sums as 16239 (same as my backups) so I don't think it's that.

A possible contributor to the problem is that I tried installing
NativeCAM but ran into problems as I already use gladevcp for a probe
screen (I'll go back to that once 2.7.7 is working).  I ran "setup.py c"
clear NativeCAM for now.

Any ideas?

(my .ini is here http://ruffle.me.uk/Mesa_Mill.ini.expanded)

linuxcnc prints....

>russell@cnc:~$ linuxcnc
>LINUXCNC - 2.7.7
>Machine configuration directory is
>Machine configuration file is 'Mesa_Mill.ini.expanded'
>Starting LinuxCNC...
>Found file(REL): ./Mesa_Mill.hal
>Found file(REL): ./custom.hal
>INFO CLASSICLADDER-   No ladder GUI requested-Realtime runs till HAL
>Found file(lib): /usr/share/linuxcnc/hallib/xhc-hb04.tcl
>xhc-hb04: waiting for XHC-HB04 device
>xhc-hb04: found XHC-HB04 device
>xhc-hb04.tcl: using std_start_pause_button
>APP: xhc-hb04-accels found: </usr/bin/xhc-hb04-accels>
>APP: monitor-xhc-hb04 found: </usr/bin/monitor-xhc-hb04>

then pops the G-Code error box, click OK and it continues....

>Waiting for component 'gladevcp' to become
>ready......./usr/bin/gladevcp:185: GtkWarning: GtkSpinButton: setting an
>adjustment with non-zero page size is deprecated
>  builder.add_from_file(xmlname)
>  ****  probe_screen GETINIINFO **** 
>   Preference file path:
>   /home/russell/linuxcnc/configs/Mesa_Mill/Mesa_Mill.pref
>   .....Xlib.protocol.request.QueryExtension
>   ....Xlib.protocol.request.QueryExtension
>   /usr/bin/gladevcp:295: GtkWarning: gtk_widget_size_allocate():
>   attempt to allocate widget with width -5 and height 19
>     gtk.main()

Not sure about those Gtk warnings... they might have been around forever
as I normally fire up LinuxCNC from an icon.

| Russell Brown          | MAIL: russ...@lls.com PHONE: 01780 471800 |
| Lady Lodge Systems     | WWW Work: http://www.lls.com              |
| Peterborough, England  | WWW Play: http://www.ruffle.me.uk         |

Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
Emc-users mailing list

Reply via email to