Quoth andy pugh.....
>On 12 October 2016 at 08:49, Russell Brown <russ...@lls.lls.com> wrote:
>> If I click 'OK' linuxcnc loads but the initial X & Y show as 4.23e+289
>> and 2.95e+240 and axis.ngc is not showing in the display.
>Is this one of them "Universal" milling machines, for milling entire universes?

The heating's come on today so it's probably expanded a bit but not that
much :-)

>It might be as simple as a position.txt file with bad numbers in it?


A) that doesn't explain the weird error message about axis.ngc.
B) the same position.txt works with 2.7.4
C) deleting position.txt doesn't fix either problem.

FWIW, position.txt contains:


I've just tried sim axis_mm.ini with 2.7.7 and it also generates the
spurious popup about "Bad character 'z' used" in axis.ngc :-(

Created a new user (to avoid config issues), logged in, ran 2.7.7 and
picked sim.axis/axis_mm......  same popup error message about "Bad
character 'z'" near line 12 in /usr/share/axis/images/axis.ngc.

If I try to open "/usr/share/axis/images/axis.ngc" from the File menu I
again get the error message.

If I try to open a previously used simple .ngc file, linuxcnc complains
that the tool (tool 1) isn't found in the tool table....  even though
tool 1 *is* plainly there if I edit the tooltable.

If I try to 'cut' axis.ngc, it wants me to home; I do that but X & Y go
from 0 to X -1.26e+58 and Y 3.11e+231.  Click run again and it pauses.
When I click pause to continue, I get the error "can't do that
(EMC_TRAJ_SET_TELEOP_ENABLE) in auto mode with the interpreter idle".

Uninstalled 2.7.7 (apt-get remove --purge linuxcnc), reinstalled 2.7.4
(apt-get install linuxcnc=1:2.7.4) and, still as my new test user, fired
up linuxcnc with sim/axis_mm.ini.

No complaints about bad characters, no silly numbers on homing and the
sim happily 'cut' LinuxCNC as expected.

Just for fun, I tried 2.7.5 and it's borked in the same way as 2.7.7.

Tried building a git pull of linuxcnc-dev but configure fails saying
python is too old (2.7 needed; lucid has 2.6.5).

Somethings very broken with 2.7.5+ on lucid :-(

So...  am I stuck on 2.7.4 ?

| Russell Brown          | MAIL: russ...@lls.com PHONE: 01780 471800 |
| Lady Lodge Systems     | WWW Work: http://www.lls.com              |
| Peterborough, England  | WWW Play: http://www.ruffle.me.uk         |

Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
Emc-users mailing list

Reply via email to