John Thornton, Hello,
I have a problem upgrading from Debian 8 to Debian 9 ( Jessie to Stretch i
think they are named ).

I followed these notes
https://gnipsel.com/linuxcnc/uspace/debian9-emc.html
I had no errors or warnings until
near the end I got this message
(while installing linuxcnc-uspace)

tomp@jessie:~$ sudo apt-get install linuxcnc-uspace
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linuxcnc-uspace : Depends: libboost-python1.62.0 but it is not installable
                   Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u2 is to
be installed
                   Recommends: linux-image-rt-amd64 but it is not
installable
E: Unable to correct problems, you have held broken packages.

i already have libboost-python 1.55   and no 1.6 listed by synaptic
I already have libstdc++ 4.9.2.10+deb8u2 ,
( i have no idea what is meant by "is to be installed" , its already there )

some info about my system:

tomp@jessie:~$ uname -a
Linux jessie 3.16.0-9-rtai-amd64 #1 SMP PREEMPT Debian 3.16.7-6linuxcnc
(2015-11-30) x86_64 GNU/Linux

tomp@jessie:~$ cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 8 (jessie)"
NAME="Debian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=debian
HOME_URL="http://www.debian.org/";
SUPPORT_URL="http://www.debian.org/support";
BUG_REPORT_URL="https://bugs.debian.org/";

any hints?

thanks
tomp

_______________________________________________
Emc-users mailing list
Emc-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/emc-users

Reply via email to