OK, I like those definitions.  Even though I just changed it I would now go 
back to calling them methods rather than functions (because this is bound when 
the functions are invoked).  Also we lost the "is" before "read" in the 
[[Getter]] definition.  So, the final form would be:

[[Getter]]  A zero-argument method called to produce the property value each 
time the property is read.

[[Setter]]  A one-argument method called with the assigned value each time the 
property is assigned. The effect of a property's [[Setter]] method may, but is 
not required to, affect the value produced by subsequent calls to the 
property's [[Getter]] method.

Allen
_______________________________________________
Es-discuss mailing list
[email protected]
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to