Paul Smith wrote:
> Hi all;
> 
> This morning just after the 2.21.5 release of Evo was announced, the 2.4
> branch of libsoup was merged to the trunk.
> 
> This version is not that easy to build: it requires a newer version of
> GLIB than is available in Ubunut Gutsy, at least (2.15 or better, while
> Gutsy contains 2.14.1)  Plus, someone reported to me that even after
> getting a new-enough GLIB, they still couldn't finish building libsoup:
> 
>         gcc -g -Wall -Wstrict-prototypes -Wmissing-declarations 
> -Wmissing-prototypes -Wnested-externs -Wpointer-arith -D_REENTRANT -o 
> .libs/context-test context-test.o test-utils.o  
> ../libsoup/.libs/libsoup-2.4.so  -Wl,--rpath -Wl,/opt/evo/lib
>         ../libsoup/.libs/libsoup-2.4.so: undefined reference to 
> `g_cancellable_is_cancelled'
> 
> So, maybe you need something even more new than suggested by the
> configure.in file!  I haven't tried this myself so I can't say for sure.
> 
> (thanks to Gareth Doutch for the heads-up!)
> 

gentoo also does not yet offer 2.15 GLIB either ( stable or ~ ).  Which kinda 
puts me in a bind, since it appears that the last successful build I got has an 
issue with logging into exchange OWA.  I guess I'll be failing over to mutt && 
tbird for a few days -- trying to decide if I wanna introduce GLIB 2.15 or not. 
  Anyone have any heads up issues re GLIB 2.15?
_______________________________________________
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers

Reply via email to