Srini,

I don't know what I'm doing wrong, but here's what I did and the output
I got (munged for privacy -- uuu=username ppp=password ddd=domain
sss=exchange server):

[EMAIL PROTECTED] ~]$ export LD_LIBRARY_PATH=/opt/samba4/lib
[EMAIL PROTECTED] ~]$ export MAPI_DEBUG=1
[EMAIL PROTECTED] ~]$ evolution
CalDAV Eplugin starting up ...
Loading Exchange MAPI Plugin

listener is constructed 
evolution-shell-Message: Killing old version of evolution-data-server...
** (evolution:2771): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:2771): DEBUG: mailto URL program: evolution
camel-mapi-store.c(166):camel_mapi_store_get_type:Reached 
get uuu mapi://[EMAIL PROTECTED]/
Find Items 9
Couldn't Get password 9
Remember mapi://[EMAIL PROTECTED]/: 0/1
Create profile with uuu ppp (****) ddd sss
profpath /home/test/.evolution/mapi-profiles.ldb
[exchange_mapi_plugin] Profile creation
Logging into the server
Login succeeded: Yeh
    [exchange_mapi_plugin] : ProcessNetworkProfile: MAPI_E_INVALID_PARAMETER 
(0x80070057)
    [exchange_mapi_plugin] ProcessNetworkProfile() : MAPI_E_INVALID_PARAMETER 
(0x80070057)
Get Default 0
Find Items 0
Delete Items sss uuu 0
get uuu mapi://[EMAIL PROTECTED]/
Find Items 9
Couldn't Get password 9
Remember mapi://[EMAIL PROTECTED]/: 0/1
Create profile with uuu ppp (****) ddd sss
profpath /home/test/.evolution/mapi-profiles.ldb
[exchange_mapi_plugin] Profile creation
Logging into the server
Login succeeded: Yeh
    [exchange_mapi_plugin] : ProcessNetworkProfile: MAPI_E_INVALID_PARAMETER 
(0x80070057)
    [exchange_mapi_plugin] ProcessNetworkProfile() : MAPI_E_INVALID_PARAMETER 
(0x80070057)
Get Default 0
Find Items 0
Delete Items sss uuu 0

It seems to be looping at the authenticate dialog.  Keeps asking for my
password, and then I get the MAPI_E_INVALID_PARAMETER stuff on the
terminal.


Thanks,
Per

On Mon, 2008-02-04 at 14:30 +0530, Srinivasa Ragavan wrote:
> Per,
> 
> You sure you did 'export MAPI_DEBUG=1' on a terminal and from the same
> terminal, you start evolution?
> 
> I'm wondering how it works for me then :(
> -Srini.
> 
> On Sun, 2008-02-03 at 23:18 -0800, Per Nystrom wrote:
> > Srini,
> > 
> > I tried MAPI_DEBUG=1, but I got the same output as I already sent
> > before.
> > 
> > BTW, I only munged out the server, domain, username, and password (it
> > shouldn't really show the password in plaintext anyway, but that's minor
> > compared to getting it to work at all).
> > 
> > Thanks,
> > Per
> > 
> > 
> > On Mon, 2008-02-04 at 12:16 +0530, Srinivasa Ragavan wrote:
> > > Per,
> > > 
> > > Nice to hear that the crash is gone.
> > > 
> > > You can do
> > > 
> > > export 'MAPI_DEBUG=1'
> > > evolution
> > > 
> > > Try authentication and paste me out the logs. It can help be get out of
> > > the barrier. Do send me privately if you think it has some sensitive
> > > information.
> > > 
> > > -Srini.
> > > On Sat, 2008-02-02 at 23:15 -0800, Per Nystrom wrote:
> > > > Hi,
> > > > 
> > > > I saw a new update showed up today in the repository so I tried it out.
> > > > The crash is gone, but I still can't get past the authenticate dialog.
> > > > Here's the terminal output:
> > > > 
> > > > [EMAIL PROTECTED] ~]$ LD_LIBRARY_PATH=/opt/samba4/lib evolution
> > > > CalDAV Eplugin starting up ...
> > > > Loading Exchange MAPI Plugin
> > > > 
> > > > listener is constructed 
> > > > evolution-shell-Message: Killing old version of evolution-data-server...
> > > > ** (evolution:10509): DEBUG: mailto URL command: evolution 
> > > > --component=mail %s
> > > > ** (evolution:10509): DEBUG: mailto URL program: evolution
> > > > camel-mapi-store.c(166):camel_mapi_store_get_type:Reached 
> > > > get uuu mapi://[EMAIL PROTECTED]/
> > > > Find Items 9
> > > > Couldn't Get password 9
> > > > Create profile with uuu ppp (****) yyy.zzz xxx.yyy.zzz
> > > > profpath /home/test/.evolution/mapi-profiles.ldb
> > > > [exchange_mapi_plugin] Profile creation
> > > > Logging into the server
> > > > Login succeeded: Yeh
> > > >     [exchange_mapi_plugin] : ProcessNetworkProfile: 
> > > > MAPI_E_INVALID_PARAMETER (0x80070057)
> > > >     [exchange_mapi_plugin] ProcessNetworkProfile() : 
> > > > MAPI_E_INVALID_PARAMETER (0x80070057)
> > > > Get Default 0
> > > > Find Items 9
> > > > Couldn't clear password
> > > > 
> > > > I'm happy to help debug, just let me know what you need me to do.
> > > > 
> > > > Thanks,
> > > > Per
> > > > 
> > > > On Mon, 2008-01-28 at 23:45 -0800, Per Nystrom wrote:
> > > > > Excellent, I'll watch for it to show up in the repository and try 
> > > > > again.
> > > > > 
> > > > > Thanks,
> > > > > Per
> > > > > 
> > > > > On Tue, 2008-01-29 at 09:22 +0530, Srinivasa Ragavan wrote:
> > > > > > Looks like a double free when the profile creation fails.
> > > > > > Per, the main problem here is why the profile creation fails. We 
> > > > > > will
> > > > > > push a debug build asap so that this can be seen.
> > > > > > 
> > > > > > -Srini.
> > > > > > On Mon, 2008-01-28 at 11:31 -0800, Per Nystrom wrote:
> > > > > > > Hello,
> > > > > > > 
> > > > > > > I installed the RPMs and dependencies from
> > > > > > > http://download.opensuse.org/repositories/home:/jjohnny:/evolution-exchange-mapi-provider
> > > > > > >  in a Fedora 8 i386 VM, started up Evolution with the required 
> > > > > > > LD_LIBRARY_PATH, tried to configure a MAPI account, and ended up 
> > > > > > > with a crash.  I posted details to the bugs wiki here:
> > > > > > > 
> > > > > > > http://www.go-evolution.org/MAPIProvider/Bugs
> > > > > > > 
> > > > > > > I'm happy to help get this moving any way I can; I have been 
> > > > > > > without
> > > > > > > Evolution-Exchange connectivity ever since my company upgraded to
> > > > > > > Exchange 2007 in December and OWA light is driving me nuts.
> > > > > > > 
> > > > > > > Thanks,
> > > > > > > Per
> > > > > > > 
> > > > > > > _______________________________________________
> > > > > > > Evolution-hackers mailing list
> > > > > > > Evolution-hackers@gnome.org
> > > > > > > http://mail.gnome.org/mailman/listinfo/evolution-hackers
> > > > > 
> > > > > _______________________________________________
> > > > > Evolution-hackers mailing list
> > > > > Evolution-hackers@gnome.org
> > > > > http://mail.gnome.org/mailman/listinfo/evolution-hackers
> > > > 
> > 

_______________________________________________
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers

Reply via email to