Hi folks,

I was able to use fingolfin’s mh:1014 forked branch of fink to bootstrap on a 
10.14.2 system and get most packages building fine, with the Apple developer 
tools and the headers installed. One problem I’m hitting is that perl5162-core 
fails (which is a dependency for texi2html which is a dependency for many other 
packages).

The build error reported several times is:

ld: library not found for -lgcc_s.10.4

i.e. during the build:

Running Mkbootstrap for DB_File ()
Processing extracted/DBidiClass.txt
chmod 644 DB_File.bs
gcc -c  -I/usr/local/BerkeleyDB/include -I/sw/include -fno-common -DPERL_DARWIN 
-no-cpp-precomp -fno-strict-aliasing -pipe -fstack-protector 
-I/usr/local/include -O3   -DVERSION=\"1.826\" -DXS_VERSION=\"1.826\"  
"-I../.."  -D_NOT_CORE  -DmDB_Prefix_t=size_t -DmDB_Hash_t=u_int32_t   DB_File.c
1 warning generated.
gcc -c  -I./zlib-src -I/sw/include -fno-common -DPERL_DARWIN -no-cpp-precomp 
-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -O3   
-DVERSION=\"2.048\" -DXS_VERSION=\"2.048\"  "-I../.."  -DNO_VIZ -DZ_SOLO   
-DGZIP_OS_CODE=3  crc32.c
cp Cwd.bs ../../lib/auto/Cwd/Cwd.bs
chmod 644 ../../lib/auto/Cwd/Cwd.bs
rm -f ../../lib/auto/Cwd/Cwd.bundle
env MACOSX_DEPLOYMENT_TARGET=10.3 cc  -L/sw/lib -bundle -undefined 
dynamic_lookup -L/usr/local/lib -fstack-protector Cwd.o  -o 
../../lib/auto/Cwd/Cwd.bundle    \
                \
          
ld: library not found for -lgcc_s.10.4
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [../../lib/auto/Cwd/Cwd.bundle] Error 1
Unsuccessful make(dist/Cwd): code=512 at make_ext.pl line 466.
make: *** [lib/auto/Cwd/Cwd.bundle] Error 25
make: *** Waiting for unfinished jobs....

I assumed this was because a gcc other than the system default was required. 
This error occurred with no fink gcc built. Attempting to build perl5162-core 
with both gcc7 and gcc8 then built prior to perl5162-core, produced the same 
failure with the same problem. This occurred without changing the CompileScript 
commands, and also with the CompileScript commands to changed to (in the case 
of gcc-7):

CompileScript: <<
#!/bin/sh -ev
 sh Configure -desr -Dcc="gcc-7" -Dcpp="-gcc-7 -E" -Dprefix=%p 
-Dccflags=-I%p/include -Dldflags=-L%p/lib -Dperladmin=none -Uinstallusrbinperl 
-Dprivlib="%p/lib/perl5-core/5.16.2" 
-Darchlib="%p/lib/perl5-core/5.16.2/darwin-thread-multi-2level" 
-Dman3dir="%p/lib/perl5-core/5.16.2/man/man3" -Dman3ext=3pm 
-Dscriptdir="%p/bin" -Duseithreads -Dinc_version_list=none 
-Adefine:startperl="#!%p/bin/perl5.16.2" -Adefine:perlpath="%p/bin/perl5.16.2"
 make
<<

so that doesn’t seem to be the explanation. Can anyone shed any light on the 
behaviour and if they can reproduce the problem?

Leigh
--
Leigh M. Smith
mailto:le...@leighsmith.com
http://www.leighsmith.com 






_______________________________________________
fink-core mailing list
fink-core@lists.sourceforge.net
List archive:
http://news.gmane.org/gmane.os.apple.fink.core
Subscription management:
https://lists.sourceforge.net/lists/listinfo/fink-core

Reply via email to