On Tue, Feb 23, 2010 at 1:27 PM, Keith Reinfeld
<keithreinf...@comcast.net>wrote:

> > How is that? I'm not iterating over that function, I call it as needed,
> > so
> > myX, myY would be reset every time.
>
> Uses the addition assignment (+=) operator.
>

My bad. It is not iteration. It is called onMouseOver, hence the value of
myX, myY cannot be predetermined nor iterated.

>
> > No:
> > displayObject.filters = [createBevel()];
>
> You are missing the point. Why run this function repeatedly when you can
> set
> 'myBevel' once and just use that?
> displayObject.filters = [myBevel];
>

function createBevel():BevelFilter
{
var bf:BevelFilter = new BevelFilter();
bf.type = BitmapFilterType.OUTER;
bf.distance = 10;
bf.highlightColor = 0xFF0000;
bf.shadowColor = 0xFFFF00;
bf.blurX = 20;
bf.blurY = 20;
return bf;
}

myBevel no longer exists!
TIA,
Susan
_______________________________________________
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders

Reply via email to