Martin Spott wrote:

"Curtis L. Olson" wrote:

Update of /var/cvs/SimGear-0.3/source/simgear/screen
In directory baron:/tmp/cvs-serv29601

Modified Files:
extensions.cxx Log Message:
FreeBSD fix.

Thank you!
Would anyone mind to comment on the two proposed changes to SimGear and
FlightGear that I posted this week:
Adding '-lpthread' to the OpenAL test in Simgear '' and
adding '-lusbhid' in FlightGear where 'libplibjs' gets linked into
binaries ?

I don't think my first attempt at an isnan() fix worked ... I ended up in an infinite loop. I've tried a less elegant/brute force approach and that seems to work. We actually got FG up and running on a FreeBSD machine tonight (woohoo!) I committed a couple more small changes to simgear and FlightGear.

There seems to be a stray segfault though someplace in the FreeBSD build that is intermittent (or maybe I should say FG works only very intermittently.) There also seems like there could be some joystick/plib problem on FreeBSD? It could also be something at the OS level? js_demo fails to find any joysticks ... any one have their usb joystick running correctly with plib apps under FreeBSD?



Curtis Olson
HumanFIRST Program
FlightGear Project
Unique text:        2f585eeea02e2c79d7b1d8c4963bae2d

_______________________________________________ Flightgear-devel mailing list [EMAIL PROTECTED] 2f585eeea02e2c79d7b1d8c4963bae2d

Reply via email to