Vincent,

Yeah, just the upper left.  I wonder if it's because FOP uses an older
version of Batik?  I tried using Batik 1.1rc3 with FOP, but that didn't
work.  The newer Batik library doesn't have backwards compatibility with FOP
0.20.1.

Scott


-----Original Message-----
From: Vincent Hardy [mailto:[EMAIL PROTECTED]]
Sent: Friday, November 02, 2001 11:56 AM
To: Batik Users
Cc: FOP List
Subject: Re: Why doesn't SVG viewBox work?


Scott,

Batik displays your example ok (I checked the current code base,
1.1rc2 and 1.1rc3).

Do you see only a quarter of the image (upper left?).
V.


Scott Moore wrote:
> 
> Hi all,
> 
> I embedding some SVG into my XSL-FO to create small graphics.  But it
> doesn't seem like the viewBox attribute works.  For instance:
> 
> <fo:block>
>  <fo:instream-foreign-object>
>     <svg xmlns="http://www.w3.org/2000/svg"; width="1in" height="1in"
> viewBox="0 0 100 100" preserveAspectRatio="none">
>       <circle cx="50" cy="50" r="49" stroke-width="2" stroke="grey"
> fill="none"/>
>     </svg>
>   </fo:instream-foreign-object>
> </fo:block>
> 
> When I run the above thru FOP, my circle is clipped.  The bottom and right
> parts of the circle are not displayed.  Why is that?  No matter what the
> actual width or height, shouldn't my coordinate system always be from 0 to
> 100 along both axis?  This SVG works fine in Adobe's SVG viewer.
> 
> I don't know if this is a Batik problem or a FOP problem, so I'm posting
to
> both lists.
> 
> Thanks,
> Scott
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [EMAIL PROTECTED]
> For additional commands, e-mail: [EMAIL PROTECTED]

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to