> 5. I don't think naming styles should be mixed without good
>     (and preferably explained) reason:
>       boolean m_bInited = false;
>     Yuck!

Actually I really like to be able to tell members from parameters and
local variables. I tend to use an _ before member variables (eg
_currentPage) though any convention  that makes it obvious what is what
is highly recommended.

for example when looking at a line like this

currentPageNumber = pageNumber + 1;

is much easier to read as

currentPageNumber = _pageNumber + 1;

> 6. There seems to be a drive to use hungarian notation.
>     While I don't have a strong feelings for or against it,
>     I'd like to note that in all projects I've watched such
>     an efford was ultimately wasted. Usage universally
>     degraded over time, and causal and inconsistent usage
>     just makes the code look ugly.

it's either an all in or not at all thing. I don't tend to use it on my

> 7. I think a bit more time should be spent to check general
>     consistency after wholesale copy&paste:
>        /**
>         * This is the top level layout manager.
>         * It is created by the PageSequence FO.
>         */
>        public FlowLayoutManager(FObj fobj) {
>     Well, bad things happen.

One of the programmers I work with insists that copy should be removed
from developers editors.


If you don't test then your code is only a collection of bugs which 
apparently behave like a working program. 

Website: http://radio.weblogs.com/0111457/

To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to