On Thu, 2002-08-15 at 20:59, Jeremias Maerki wrote:
> I know that's probably unpopular but I usually like to reference member
> variables like this:
> this.currentPageNumber = pageNumber + 1;

I used to use that convention except that someone always forgets to do
it and your back where you started.

what about

currentPageNumber = m_pageNumber + 1;

> That is a bit more to write but I don't particularly like underscores in
> names.
> 
> On 15.08.2002 12:40:06 Kevin O'Neill wrote:
> > 
> > > 5. I don't think naming styles should be mixed without good
> > >     (and preferably explained) reason:
> > >       boolean m_bInited = false;
> > >     Yuck!
> > 
> > Actually I really like to be able to tell members from parameters and
> > local variables. I tend to use an _ before member variables (eg
> > _currentPage) though any convention  that makes it obvious what is what
> > is highly recommended.
> > 
> > for example when looking at a line like this
> > 
> > currentPageNumber = pageNumber + 1;
> > 
> > is much easier to read as
> > 
> > currentPageNumber = _pageNumber + 1;
> > 
> 
> 
> Jeremias Maerki
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [EMAIL PROTECTED]
> For additional commands, email: [EMAIL PROTECTED]
> 
-- 
If you don't test then your code is only a collection of bugs which 
apparently behave like a working program. 

Website: http://radio.weblogs.com/0111457/


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to