I've had my problems with using SSH2. I finally tried SSH1 and it worked.
I suggest you create a SSH1 key pair and retry with this.

There are two ways you can work with putty. Either you create a tunnel
for CVS which has the benefit that the connection is always there as
soon as you have connected to the server.

The other way is to use plink which has to build a connection everytime
you access CVS. Select SSH authentication in WinCVS and specify the full
path to plink.exe as SSH client. You need to have Putty Password agent
running for that.

Tell me if you need more info. Good luck!

On 01.03.2004 10:32:28 Chris Bowditch wrote:
> I know this subject has come up before, but I still cant quite get 
> things working after trawling through the archives.
> I'm using WinCVS 1.3 and Putty to connect to the cvs.apache.org. My 
> understanding was that using SSH keys was optional but strongly 
> encouraged. So I had a go at creating the private/public key pairs, and 
> put the public key into .ssh directory on my apache home, and specified 
> the private key file to Putty, but when I click "open" in Putty and 
> enter userid/password I get a message saying
> Trying public key authentication.
> Key is of wrong type (PuTTY SSH2 private key)
> Any ideas, what this means? I specified SSH2 (RSA) when I generated my 
> keys. I noticed in the archives that some people have authorized_keys 
> and others have authorized_keys2 file, which do I need? I tried both, 
> but I still got the same message.
> Thinking that SSH is not strictly required for write access, I had a go 
> at updating my description on the Team page, but WinCVS says:
> cvs [server aborted]: "commit" requires write access to the repository

Jeremias Maerki

Reply via email to