I agree with Vincent that common acronyms should not be changed to words
(initial cap only) just to satisfy findbugs; this is a case where exclusions
to findbugs should be used, or even a blanket exclusion; furthermore, the
term "Namespace" in XML is well established as a single word and should not
be divided into two words "NameSpace" to satisfy findbugs;

the problem here (and with checkstyle) is that some policy rules having to
do with style or design do not have sufficient universal consensus to simply
adopt without question; in this case, I do not believe there is a consensus
(at least Vincent and I do not agree with the renaming), so I suggest
another way be found to eliminate these findbugs "warnings".

regards,
glenn

On Thu, Nov 18, 2010 at 8:42 AM, Simon Pepping <spepp...@leverkruid.eu>wrote:

> render.AbstractGenericSVGHandler.getNamespace -> getNameSpace
> render.intermediate.extensions.AbstractAction.setID -> setId
> render.intermediate.extensions.AbstractAction.getID -> getId
> render.intermediate.extensions.AbstractAction.hasID -> hasId
> render.intermediate.extensions.AbstractAction.getIDPrefix -> getIdPrefix
> render.intermediate.extensions.URIAction.getIDPrefix -> getIdPrefix
> render.XMLHandler.getNamespace -> getNameSpace
> render.ps.PSImageFormResource.getImageURI -> getImageUri
> render.xml.XMLXMLHandler.getNamespace -> getNameSpace
> render.afp.AFPRendererImageInfo.getURI -> getUri
> fonts.type1.PFMFile.getPostscriptName -> getPostScriptName
> tools.TestConverter.setBaseDir -> setBasedir
> tools.anttasks.Fop.setUserconfig -> setUserConfig
> tools.anttasks.Fop.getUserconfig -> getUserConfig()
> tools.anttasks.Fop.setFofile -> setFoFile
> tools.anttasks.Fop.getFofile -> getFoFile
> tools.anttasks.Fop.setThrowexceptions -> setThrowExceptions
> tools.anttasks.Fop.getThrowexceptions -> getThrowExceptions
> apps.PageSequenceResults.getID -> getId
> fo.FOText.getBaseLineShift -> getBaselineShift
> cli.CommandLineOptions.getFOFile -> getFoFile
> cli.CommandLineOptions.getXMLFile -> getXmlFile
> cli.CommandLineOptions.getXSLFile -> getXslFile
>
> On Wed, Nov 17, 2010 at 09:29:06PM +0100, Simon Pepping wrote:
> > On Wed, Nov 17, 2010 at 07:45:31PM -0000, spepp...@apache.org wrote:
> > > Author: spepping
> > > Date: Wed Nov 17 19:45:27 2010
> > > New Revision: 1036179
> > >
> > > URL: http://svn.apache.org/viewvc?rev=1036179&view=rev
> > > Log:
> > > findbugs-reported bug squashing; 959 bugs left (findbugs 1.3.9)
> >
> > findbugs reports naming problems in public methods, such as setters
> > and getters. I resolved those problems. But in doing so, in principle
> > I am changing the public API. I do not think that every public method
> > is really in use by other applications. Let me know when I go too far
> > in those changes, harming applications that depend on fop.
> >
> > Simon
> >
>

Reply via email to