Any news on the brightness? My X220 came and FreeBSD installs and boots
fine with MBR. But like you said brightness control is not working and I am
stuck at max. Even with me 9cell battery, it brings it down to 5 hours
instead of 8-9 with a slightly dimmer setting.

P.S. I didn't have to touch anything in BIOS.

 Ditch the's grainy under linux, probably would be the same
> under FreeBSD...haven't even tried.
> Intel wireless is THE way to go...that Realtek is barely supported on
> Linux (I believe 8192SU is still staging drivers...)
> FreeBSD only legacy boots, however "UEFI USB Support" must be on to allow
> USB booting for some reason.
> I have's very nice, but still no brightness yet. I'll get a
> chance to look at again this weekend most likely. I think it's just an
> issue with our acpi_ibm that isn't talking to the embedded controller right.
> Resume works, but the screen is not on. I can now confirm it is *off* and
> not just "dimmed/no backlight". Setting BIOS to use an external monitor and
> disabling internal exhibits same behavior as internal display, i.e external
> monitor set as BIOS primary does not come back from power save. I have
> tried typing dpms force commands, did not work.
> Once resume & brightness work, it will be great for FreeBSD...everything
> else seemed fine, although I have not used fingerprint reader or card
> reader...
> An interesting note is that the BIOS does whitelist the wireless card, and
> the wwan slot defaults to being a mSATA until it detects a whitelisted USB
> ID or perhaps has no PCIe lines...not sure but my ral card I'm working with
> will not detect in the second slot at all. The slot may start as PCIe only
> in earlier bios, haven't checked (google x220 egpu & x220 msata issue).
> Matt

Lyubomir Grigorov (bgalakazam)
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to