Hi Kevin,

that is a good news but I have a RELEASE therefore if I am not wrong I
should recompile my kernel. Did I miss something?

Cheers,
Daniele.


2014-07-26 18:52 GMT+02:00 Kevin Oberman <rkober...@gmail.com>:

> On Sat, Jul 26, 2014 at 9:31 AM, Kevin Oberman <rkober...@gmail.com>
> wrote:
>
>> On Sat, Jul 26, 2014 at 1:46 AM, Daniele Mazzotti <kappe...@gmail.com>
>> wrote:
>>
>>> Hi,
>>>
>>> thanks again for your precious help. The suspend mode is not working yet
>>> as VESA option is still in my kernel configuration. I wanted to wait before
>>> removing it as I was not sure that intel video driver would have worked. My
>>> intention was to have a working setup with intel and being able to switch
>>> amongst vt(s) before getting rid of vesa, as I would peferer having the
>>> possibility to switch amongst vt(s)  than putting my laptop to suspend.
>>>
>>> By the way I have a 10-RELEASE therefore I suspect I will have to
>>> recompile the kernel with VT. Did I get you right?
>>>
>>> I googled a bit and it seems that the only thing I have to do is to add
>>> these devices to my kernel:
>>>
>>> device vt
>>> device vt_vga
>>>
>>> This is the source I am referring to: https://wiki.freebsd.org/Newcons.
>>> Is this it?
>>>
>>> Cheers and thanks again,
>>> Daniele.
>>>
>>>
>> Maybe and maybe not. The wiki page needs updating.
>>
>> Look at /sys/ARCH/conf for a VT configuration. If it is there, just build
>> a kernel with:
>> # make buildkernel kernconf=VT && make installkernel kernconf=VT
>> (You probably want to  add a reasonable -j option for your hardware to
>> the buildkernel.)
>>
>> If you don't have a VT config file, than just set the kern.vty=vt
>> loadable in /boot/loader.conf. No need to build a new kernel.
>>
>
> I just looked at teh repo an can say that just adding kern.vty=vt to
> /boot/loader.conf will work on head r 267965 or newer and 10-Stable r268366
> or newer. Looks like this has not been MFCed to 9.
>
> --
> R. Kevin Oberman, Network Engineer, Retired
> E-mail: rkober...@gmail.com
>
>
>
>>>
>>> 2014-07-26 8:14 GMT+02:00 Kevin Oberman <rkober...@gmail.com>:
>>>
>>>> On Fri, Jul 25, 2014 at 3:19 PM, Bykov Vladislav <> <envol...@gmail.com
>>>> > wrote:
>>>>
>>>>> On Fri, Jul 25, 2014 at 10:43:11PM +0200, Daniele Mazzotti wrote:
>>>>> > The error I get anytime I try to switch between terminals is the
>>>>> following
>>>>> > one " drmDropMaster failed: Unknown error: -22"
>>>>> This is okay, if you can't switch back to tty after starting Xorg in
>>>>> KMS
>>>>> mode using old syscons driver. There is already work going on with new
>>>>> driver, vt. I didn't test it though.
>>>>>
>>>>> At least, suspend is works now?
>>>>>
>>>>
>>>> Try adding  kern.vty=vt to /boot/loader.conf. In recent 9-stable,
>>>> 10-stable, and head kernels, this is all it takes to switch to vt(4). If
>>>> you have an older kernel or are running any release, you will need to
>>>> rebuild the kernel using the VT configuration. The loader option may have
>>>> made 9.3, but I'm not sure. I don't believe vt(4) is available for 8.
>>>> --
>>>> R. Kevin Oberman, Network Engineer, Retired
>>>> E-mail: rkober...@gmail.com
>>>>
>>>>
>>>
>>>
>>
>
_______________________________________________
freebsd-acpi@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-acpi
To unsubscribe, send any mail to "freebsd-acpi-unsubscr...@freebsd.org"

Reply via email to