On Thu, Dec 19, 2013 at 10:33:32AM -0500, Larry Baird wrote:
L> > On Thu, Dec 19, 2013 at 09:51:16AM -0500, Larry Baird wrote:
L> > L> Does anybody else have issues with running i386 FreeBSD 10 under 
Virtual Box?
L> > L> I have been running a number of different versions of FreeBSD under 
L> > L> Box for some time without any issues.  Last week I installed amd64 
L> > L> 10 rc1 without any issue.  Yesterday I decided to try i386 FreeBSD 10 
L> > L> Install seemed to go ok.  After initial boot I tried to update ports 
L> > L> portsnap.  I got a message about corrupted zip file.  I initially 
L> > L> something was wrong with portsnap.  Nothing I tried seemed to fix the 
L> > L> so I moved on.  I tried to build subversion. I got coredumps from cc 
and was
L> > L> unable to build any ports. I decided something must have gone wrong 
with the
L> > L> install.  I reinstalled and got the same results. I then downloaded and
L> > L> installed i386 FreeBSD 10 rc2.  I had the same issues.  So I then 
L> > L> FreeBSD 10 rc1 amd64.  No issues, everything seemed to behave as 
L> > L> I then installed FreeBSD 9.2 i386.  No issues.  I then used subversion 
L> > L> mergemaster to upgrade to FreeBSD 10 stable.  After doing upgrade, I 
L> > L> again get coredumps from cc.
L> > L> 
L> > L> In case it matters Virtual box is version 4.3.4 running under Windows 7 
64 bit.
L> > L> 
L> > L> Anybody else having issues with i386 FreeBSD 10?
L> > 
L> > Can you please set
L> > 
L> > vfs.unmapped_buf_allowed=0
L> > 
L> > in boot loader and try to reproduce the problem?
L> This seemed to fix the issue.  I can now use portsnap and I have successfully
L> compiled serveral ports.  
L> Is "unmapped_buf_allowed" a virtualization issue or an i386 issue?

We do not yet sure diagnosis yet, but this looks like a bug in the VirtualBox.

Totus tuus, Glebius.
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to