I had a perfectly working PXE-booting environment, but now it fails at kernel
boot stage.

Client starts to boot, and var/log/xfer shows the pxeboot file being
transferred from server:
  in.tftpd[34792]: RRQ from filename pxeboot
  tftpd[5013]: Filename: 'pxeboot'
  tftpd[5015]: Mode: 'octet'
  tftpd[5015]: read request for //pxeboot: success

Then BTX starts to boot the kernel but fails with:
  pxe_open: server addr:
  pxe_open: server path: /
  pxe_open: gateway ip:
  NFS MOUNT RPC error: 72
  can't load 'kernel'

Then drops to BTX's rescue command prompt.
* NFS path is visible in "showmount -e" and I have disabled NFS_V4 to debug
the problem.
* The BTX cli gives "failed RPC struct is bad" message to "ls" command.
* rpcbind complains "cannot get information for tcp6 & udp6. My kernel has
IPV6 disabled and etc/rc.conf has {ipv6_activate_all_interfaces="NO" \
* etc/rc.conf has these as well and I tried the problem with NFS_V3 (disable
V4) but got same result:
mountd_flags="-r -n -o -l -h"
nfsd_flags="-u -t -n 4 -h"
* The only other log entry I can find is:
inetd[4949]: madvise() failed: Operation not permitted
inetd[5012]: setpriority 'root' (daemon): Permission denied
inetd[5014]: setpriority 'root' (daemon): Permission denied

Any suggestions on what else I can try to debug this thing?

View this message in context: 
Sent from the freebsd-current mailing list archive at Nabble.com.
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to