please let me know if this isn’t the best list to ask these particular 
questions, and which list is.  I have an Acer Travelmate P653 model MS2352 with 
an Intel HD4000 (I think) Gen 3 graphics card.  Unfortunately pciconf, and 
dmesg do not show useful information other than intel gen3 graphics.  This 
laptop doesn’t give me the option to disable CSM.  It also boots whatever is 
available whether EFI only is selected or not.  FreeBSD 10.1 worked on this 
laptop, and loaded i915kms properly.  PCBSD has always worked, and still works 
even with their 11 CURRENT images which no longer use grub.

Sometime after changes in FreeBSD 10-STABLE, 10.2 onwards, and recent 11 
CURRENT the resolution no longer sets properly when using UEFI boot.  It now 
boots with a 640x480 resolution, and kldload i915kms results in a black screen. 
 I have not been able to grab a debug log, or crash dump even with all of the 
debugging features turned on.  I cannot ssh into the laptop when this panic 
occurs, and the screen is black so I can’t really see what happened.  I’m 
curious if there is anything else I can do besides enabling dumpdev or kldload 
-v i915kms > output.txt that doesn’t give me any detail.  Nothing shows up in 
/var/crash or whatever the directory was.

I’ve noticed if I compile from PCBSD’s fork of FreeBSD current source on top of 
FreeBSD it works.  I have been unable to track down the difference at this 
point.  I’ve been working on it for a few months but I have not figured it out. 
 I would appreciate any help I could get in tracking down the cause to fix the 
problem for others.  I can’t seem to find that it’s a problem for anyone else 
however after months of research.

I did find one interesting thing.  If I mount the EFI partition, and replace 
/mnt/efi/boot/bootx64.efi (boot1.efi) with loader.efi by cp /boot/loader.efi 
/mnt/efi/boot/bootx64.efi i get full 1366x768 console resolution.  I can then 
use scfb at least if I delete the i915kms* drivers to start X.

I tested boot1.efi on a mac, and it of course sets the proper 1920x1080 
resolution it should.  I am curious what the difference is between boot1.efi, 
and loader.efi.  Is a device id or something missing from boot1.efi for my 
laptop to set the proper resolution?  It’s it the fact that I can’t disable 
CSM, and it’s somehow booting non EFI?  Can I remove certain things don’t force 
EFI only, or somehow force FreeBSD to disable CSM?  Can I somehow roll an EFI 
only release of FreeBSD for further testing?  If so what would I need to 
remove, or disable?  Does anyone have any suggestions on what I could try to 
gather dump information as well regarding the i915kms lockup?

Joe Maloney

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to