On 02/24/16 00:58, Miguel C wrote:
I just noticed the last messages were never CC'ed to the list

On Wed, Feb 10, 2016 at 8:56 PM, OtacĂ­lio <otacilio.n...@bsd.com.br> wrote:

Miguel, I have noted that on my system, sometime I get a file not found
error, like your problem. So, I unplugged the webcam and plug it again and
it works. It is no frequently but occurs. Your camera is fixed or you can
try something like this?

Nah its fixed :P

Its an acer ultrabook, the devices is conencted as a usb but its not like I
can plug it of  unless I remove the LCD or something :P

I was jsut think that this might be driver related, which seems to be uvc:

% v4l2-dbg -D
Driver info:
         Driver name   : uvcvideo
         Card type     : 1.3M HD WebCam
         Bus info      : usb-/dev/usb-/dev/usb
         Driver version: 2.6.38
         Capabilities  : 0x84200001
                 Video Capture
                 Extended Pix Format
                 Device Capabilities

maybe its a bug in the driver that presenting something unexpected to
/dev/video, I was just tried with ffpmeg, recompiled with v4l support and
get the same error using -i /dev/video

[video4linux2,v4l2 @ 0x80ac6f000] ioctl(VIDIOC_STREAMON): Device not
/dev/video0: Device not configured


Can you try to get a newer version of webcamd:

pkg install -f webcamd

Need to run the command below to make webamd re-attach.

Further, try "usbconfig -d ugenX.1 reset", where X is the bus number for your webcam device.

Else it is possible to compile webcamd with debugging on, and run it in the foreground to see what the error is about.

freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to