On Wed, Feb 24, 2016 at 5:32 PM, Miguel C <miguelmcl...@gmail.com> wrote:

> On Wed, Feb 24, 2016 at 7:28 AM, Hans Petter Selasky <h...@selasky.org>
> wrote:
>> On 02/24/16 00:58, Miguel C wrote:
>>> I just noticed the last messages were never CC'ed to the list
>>> On Wed, Feb 10, 2016 at 8:56 PM, OtacĂ­lio <otacilio.n...@bsd.com.br>
>>> wrote:
>>> Miguel, I have noted that on my system, sometime I get a file not found
>>>> error, like your problem. So, I unplugged the webcam and plug it again
>>>> and
>>>> it works. It is no frequently but occurs. Your camera is fixed or you
>>>> can
>>>> try something like this?
>>> Nah its fixed :P
>>> Its an acer ultrabook, the devices is conencted as a usb but its not
>>> like I
>>> can plug it of  unless I remove the LCD or something :P
>>> I was jsut think that this might be driver related, which seems to be
>>> uvc:
>>> % v4l2-dbg -D
>>> Driver info:
>>>          Driver name   : uvcvideo
>>>          Card type     : 1.3M HD WebCam
>>>          Bus info      : usb-/dev/usb-/dev/usb
>>>          Driver version: 2.6.38
>>>          Capabilities  : 0x84200001
>>>                  Video Capture
>>>                  Streaming
>>>                  Extended Pix Format
>>>                  Device Capabilities
>>> maybe its a bug in the driver that presenting something unexpected to
>>> /dev/video, I was just tried with ffpmeg, recompiled with v4l support and
>>> get the same error using -i /dev/video
>>> [video4linux2,v4l2 @ 0x80ac6f000] ioctl(VIDIOC_STREAMON): Device not
>>> configured
>>> /dev/video0: Device not configured
>> Hi,
>> Can you try to get a newer version of webcamd:
>> pkg install -f webcamd
> This would just reinstall the one I already have (cause I do have the
> latest version from ports), but in any case I did try to reinstall and
> recompile a few times.
>> Need to run the command below to make webamd re-attach.
>> Further, try "usbconfig -d ugenX.1 reset", where X is the bus number for
>> your webcam device.
> Tried that too, I need to restart webcamd after doing it, but it still
> gets me the same result.
>> Else it is possible to compile webcamd with debugging on, and run it in
>> the foreground to see what the error is about.
> I was assuming it was a driver or permissions issue, but its certainly a
> good idea to see if I get any debug info from webcamd, recompiling with
> DEBUG on.
> FYI today even cheese fails with:
> "cheese:18761): cheese-WARNING **: Device '/dev/video0' is busy:
> gstv4l2object.c(3267): gst_v4l2_object_set_format_full ():
> /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin35/GstV4l2Src:v4l2src1:
> "
> This is after restarting and I have not upgrade kernel/userland since I've
> noticed this issue so that's strange.
> Ok after recompiling with debug and running in foreground I see what seems
to be a driver related error:

% sudo webcamd -N 1-3M-HD-WebCam-SuYin
multimedia/webcamd r2d2
: USB HID core driver
Linux video capture interface: v2.00
lirc_dev: IR Remote Control driver registered, major 14
IR NEC protocol handler initialized
IR RC5(x/sz) protocol handler initialized
IR RC6 protocol handler initialized
IR JVC protocol handler initialized
IR Sony protocol handler initialized
IR SANYO protocol handler initialized
IR LIRC bridge handler initialized
IR XMP protocol handler initialized
b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded
uvcvideo: Unable to create debugfs directory
USB Video Class driver (1.1.1)
cpia2: V4L-Driver for Vision CPiA2 based cameras v3.0.1
pvrusb2: V4L in-tree version:Hauppauge WinTV-PVR-USB2 MPEG2 Encoder/Tuner
pvrusb2: Debug mask is 31 (0x1f)
USBVision USB Video Device Driver for Linux : 0.9.11
em28xx: Registered (Em28xx v4l2 Extension) extension
em28xx: Registered (Em28xx dvb Extension) extension
Attached to ugen0.5[0]
uvcvideo: Found UVC 1.00 device 1.3M HD WebCam (064e:c321)
Creating /dev/video0
uvcvideo: Failed to submit URB 0 (-32). <------------------ Shows if I run
cheese (nothing happens here if I run pwcview

>> --HPS
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to