Ian Lepore wrote on 03/28/16 05:29 AM:


I updated to r297281 with this quirk applied. Sadly, it doesn't
anything - controllers still not recognized. I also tried to boot
revision with disabled hw.sdhci.enable_msi=0, that I applied earlier.

I finally found some time today to give this stuff a try on my one x86
system that has an sdhci controller in it.  Unfortunately, everything
just works fine.  I tried with a GENERIC kernel that has those devices
compiled in, and I tried taking them out and loading sdhci_pci, mmc,
and mmcsd as modules, and everything just worked both ways.

The only thing I can think of now is to turn up the debugging levels.
  That's going to generate a lot of spewage, but if you paste/upload the
output somewhere I'll look through it.  So try setting:


in either loader.conf or via sysctl before you kldload the modules.  If
the sdhci output is too trashed with interrupt info, maybe lower it to

-- Ian

Ian, not much changed with setting this knobs in loader.conf except of showing the "REGISTER DUMP" table, that I already sent you in one of earlier responses. Here is the full dmesg: https://dpaste.de/GeaT/raw

Also nothing is showing in messages/console upon plugging an SD card. Maybe I should enable some debug in kernel to make it show anything? Here is my kern conf: https://dpaste.de/0v9k/raw It's mostly generic, but with debug bits disabled.

Mine mmc/sdhci stuff is compiled in and shown in kldstat output:
[rm@smsh-zfs ~]> kldstat -v | grep mmc
                238 sdhci_pci/mmc
                187 mmc/mmcsd


T.O.S. Of Reality
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to