Ian Lepore wrote on 03/26/16 12:33 AM:
On Fri, 2016-03-25 at 23:11 +0200, Ivan Klymenko wrote:
On Sat, 26 Mar 2016 00:05:13 +0300
Ruslan Makhmatkhanov <r...@freebsd.org> wrote:

Ivan Klymenko wrote on 03/25/16 11:41 PM:
On Fri, 25 Mar 2016 23:33:45 +0300
Ruslan Makhmatkhanov <r...@freebsd.org> wrote:


I have this in pciconf output:

none1@pci0:36:0:0:      class=0x088000 card=0x167e103c
chip=0x2392197b rev=0x30 hdr=0x00
       vendor     = 'JMicron Technology Corp.'
       device     = 'SD/MMC Host Controller'
       class      = base peripheral

none2@pci0:36:0:3:      class=0x088000 card=0x167e103c
chip=0x2393197b rev=0x30 hdr=0x00
       vendor     = 'JMicron Technology Corp.'
       device     = 'MS Host Controller'
       class      = base peripheral

And my SD-card controller is not working anymore (it worked on
-current on the same laptop year or two ago). Do I need to load
some kld to make it working, or support for this controllers
dropped altogether for some reason? I have mostly vanilla
at r296772, but it actually stopped to work much earlier.


I would also like to clarify about this problem was drawn up a


Hah, I even see my comment from 2014 in this PR.

I have it broken just from that moment to this day.
uname -a
FreeBSD nonamehost.local 11.0-CURRENT FreeBSD 11.0-CURRENT #0
Thu Mar 24 15:15:39 EET 2016
ivan@nonamehost.local:/media/da0s1/obj/usr/src/sys/mk11  amd64

So looks like it was
broken not in r292180 as Ian pointed, but much-much earlier.
I'll try to update to fresh -current first.

That PR has a very small range, r271081-138, but I don't any changes in
that range related to sdhci, or to pci.  The PR doesn't say anything
about how the device "doesn't work".  Does the sdhci device show up in
dmesg, but the sd card is never detected, or does sdhci not even

-- Ian

If memory serves me right, I first run into this problem about 2-6 months before I added a comment to the PR, that it doesn't works for me on r271687. Doesn't work means driver doesn't attaching to the hardware, so plugging memory card doesn't trigger any changes in system - still no driver attached to hardware and no device, that I can mount, appeared. But I sure that it worked without any intervention before - I just plugged an SD-card and it auto-mounted with my DE. But after that there is just nothing to mount. The reason why I missed particular revision it stopped working is because I'm using SD not too often (once a year or something) to update car music playlist. I can try to boot earlier releases like 10.0 etc, to find out revision on what it works.

Anyway, Ian, if you may suggest something, I'm open to any tests and providing all the infos that is needed to debug the issue. Especially, because there is at least three person that are facing the same issue.


T.O.S. Of Reality
freebsd-current@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"

Reply via email to