Christopher Masto wrote:
> On Fri, Jun 09, 2000 at 01:14:35PM -0400, Jeroen C. van Gelderen wrote:
> > I'm not sure it is a good idea to name this variable VMWare as
> > that is implementation specific. It may be better to have a var
> > named 'emulation' set to 'none' or 'vmware' or 'bochs' or ...
> Mmm.. or, giving forth the ability to do in/out instructions, so the
> non-generic code would be entirely in the add-on forth piece.  I'm
> not sure if there are any security implications there.. at boot time
> the machine is essentially as single-user as it's ever going to be.

I prefer 'emulation' being set to 'native', 'vmware' etc.  Consider that
there is IA64, Alpha, sparc, ppc etc to deal with.  Teaching the ficl
scripts to do inb/outb would be bad.  It would be much better to have a
generic mechanism for informing the loader about possible emulation
environments, eg you are using the IA64 emulator under an x86 box, or an
x86 emulator on an Alpha, or an Alpha SIMOS emulation under x86, or

"All of this is for nothing if we don't go to the stars" - JMS/B5

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to