Ya know, I never thought about checkign /var/log/messages on mine to see
if it was, in fact, booting (I thought it was, it sounded like it was, but
I couldn't think of a way to check) ...

Using kernel sources up-to-date as of a few hours ago, I've tried to pare
my optimzatins down to a simple '-O -pipe', and I'm getting the same thing
as you, where I effectively get:

Booting kernel ...

on my screen, and that's the end of it.  Looking at /var/log/messages, it
looks like I am getting a full reboot happening, right down to
initializing 'vmmon', but nothing to my screen.

I've been trying to follow the -current list to see if any ideas/solutions
pop up, but the only things I've noticed so far have revolved around
optimization issues, but its more then possible that I missed a message

My last good kernel, that boot'd fine, is:

@(#)FreeBSD 5.0-CURRENT #0: Wed Jun 14 01:03:00 ADT 2000

With every other one since resulting in the above ...

On Sun, 18 Jun 2000, Bosko Milekic wrote:

>   I've recently cleaned up and updated my sources, saving some changes
>   I made elsewhere. I performed a buildworld, installworld, etc. yesterday
>   night with no problems.
>   When I rebuilt my kernel, after having collected the appropriate hints
>   for the system and modified my kernel configuration file appropriately, I
>   had some trouble booting it. The loader would load the kernel into memory
>   but when it was time to `boot' it, I was not able to see anything on the
>   console, this includes the initial copyright message. Furthermore, my
>   keyboard was unresponsive. However, I could tell that the kernel was
>   booting nonetheless (even though I could not see it), judging by the hard
>   disk drives' activity (and upon checking /var/log/messages after I booted
>   with my previously saved kernel).
>   I then decided to rebuild the kernel with the hints statically compiled
>   in, and this worked fine, and the kernel booted properly. Note that I did
>   not use any notable optimisation flag during the build, and that this is
>   all on i386 architecture.
>   However, I decided to build a kernel with profiling support this morning
>   (config -p KERNEL, etc.), and I left the hints compiled in statically.
>   The kernel built fine, but when it came time to boot it, again, no
>   response from keyboard, nothing at the console. This time though, the
>   kernel wasn't even booting.
>   Has anybody noticed/tried this recently? Am I forgetting something?
>   Cheers,
>   Bosko.
> --
>  Bosko Milekic  *  Voice/Mobile: 514.865.7738  *  Pager: 514.921.0237
>     [EMAIL PROTECTED]  *  http://www.technokratis.com/
> To Unsubscribe: send mail to [EMAIL PROTECTED]
> with "unsubscribe freebsd-current" in the body of the message

Marc G. Fournier                   ICQ#7615664               IRC Nick: Scrappy
Systems Administrator @ hub.org 
primary: [EMAIL PROTECTED]           secondary: scrappy@{freebsd|postgresql}.org 

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to