It's worth cc'ing Archie on this....

Archie, it seems people are having problems using PPPoE since your 
ng_ether changes.  Any suggestions ?

> Brian Somers <[EMAIL PROTECTED]> writes:
> > > I see literally the exact same thing.
> > > I thought it was just my screwup, as i had installed 0609-CURRENT (the
> > > latest installs don't work, at least, on my desktop, so i picked the one
> > > from my birthday :P), which worked fine, then cvsup'd, installed the new
> > > kernel, did a make world, rebooted, and pppoe no longer worked.
> > > tcpdump shows the same thing you are seeing.
> > 
> > Please try the latest version of ppp.  It *should* try to load the 
> > ng_ether node now.  This is a requirement for new kernels.
> > 
> > Alternatively, kldload ng_ether before starting ppp.
> > 
> Doesn't help.
> I've just about narrowed the problem down to a kernel change.
> I can use an old kernel, with the new modules (including ng_ether, which is only 
>compiled into my new kernel, not my old one), and it works fine.
> I can use either version of ppp (06-09, or one from today), and it doesn't change 
>anything (IE it either works or doesn't, depending on which kernel i use).
> I can't use a new kernel, with netgraph compiled into it (all the ones i use), with 
>or without older modules.
> I'm about to test a new kernel, without netgraph compiled into it, with older 
>netgraph modules.
> I'll email back how it goes.
> --Dan

Brian <[EMAIL PROTECTED]>                        <brian@[uk.]>
      <>                   <brian@[uk.]>
Don't _EVER_ lose your sense of humour !

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to