X-Mailer: ELM [version 2.5 PL3]
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

I'm not sure if this is the correct list or not - apologies if
it's wrong.

I just updated a machine with cvsup for the first time - and may
have done something wrong.  

When I rebuilt everything and boot a uname gives me 5.0-CURRENT.
[I picked the wrong one as I guess I wanted release - but that's
not the problem].

Everything appears fine execpt during boot I get a symbol not found
and a core dump.
Copyright (c) 1992-2000 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.0-CURRENT #0: Wed Dec 27 20:35:44 EST 2000
    [EMAIL PROTECTED]:/usr/obj/usr/src/sys/BILVER
Timecounter "i8254"  frequency 1193182 Hz
Timecounter "TSC"  frequency 179629093 Hz
CPU: Pentium Pro (179.63-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x619  Stepping = 9
real memory  = 67108864 (65536K bytes)
config> di sn0
[stuff deleted]
Preloaded userconfig_script "/boot/kernel.conf" at 0xc049909c.
Pentium Pro MTRR support enabled
md0: Malloc disk
WARNING: Driver mistake: destroy_dev on 154/0
********** what's this? *****************
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> at pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
Correcting Natoma config for non-SMP
isab0: <PCI-ISA bridge> at device 7.0 on pci0
[more standard stuff deleted]
ep0: <3Com 3C509-TPO EtherLink III> at port 0x300-0x30f irq 11 on isa0
ep0: Ethernet address 00:60:08:02:d0:14
unknown: <PNP0501> can't assign resources
unknown: <PNP0400> can't assign resources
unknown: <PNP0700> can't assign resources
unknown: <ESS0106> can't assign resources
unknown: <PNP0f13> can't assign resources
unknown: <PNP0c02> can't assign resources
unknown: <PNP0303> can't assign resources
DUMMYNET initialized (000608)
IPv6 packet filtering initialized, default to accept, logging limited to 100 
IP packet filtering initialized, divert enabled, rule-based forwarding enabled, 
default to accept, logging limited to 100 packets/entry by default
BRIDGE 990810, have 9 interfaces
-- index 2  type 6 phy 0 addrl 6 addr
IP Filter: v3.4.13 initialized.  Default = pass all, Logging = enabled
ad0: 19541MB <Maxtor 52049H4> [39703/16/63] at ata0-master WDMA2
acd0: CDROM <TOSHIBA CD-ROM XM-5602B> at ata1-master using PIO3
Mounting root from ufs:/dev/ad0s2a
link_elf: symbol tsleep undefined
***********************************   < first error
Old-style KLD file fire_saver found
link_elf: symbol exit undefined
************************************  <next one
pid 215 (ldconfig), uid 0: exited on signal 11 (core dumped)
************************************************************* <3rd
link_elf: symbol tsleep undefined
************************************ <last one
ep0: promiscuous mode enabled

And from this point, all seems ok.

In the / is an ldconfig.core file.

Can anyone point me where to go next?

This happened yesterday, and I cvsuped it again today, and did
make buildworkd, buildkernel, install kernel, and the same thing

Some of the config in the 5.0 was new to me so in the kernel
I uncommeted the static, as I tried a couple of things on the
'hints' file, and couldn't seem to get it just right.

Not having played with a debugger in years, I ran gdb on it
and it says it was a segmentation fault, and I don't know where to
go from here.

Any pointers will be appreciated.


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to