On Tue, Feb 06, 2001 at 11:21:12PM +0900, [EMAIL PROTECTED] wrote:
> Today I tried with 4.2-RELEASE (sorry not -current) and,
> 1. Boot up the 4.2-RELEASE with GENERIC kernel.
> 2. Connect MO drive with PC Card SCSI(ncv).
> 3. Insert PC Card without medium in the MO drive.
> 4. The pccardd automatically run camcontrol rescan.
> 5. Message says that da0 is 0MB capacity.
> 6. Run fdisk da0
> 7. got panic with divided by zero. 
> Probably divided by zero is caused at line 737 or 748 in the
> scsi_low_action() in cam/scsi/scsi_low.c because of ccg->block_size or 
> secs_per_cylinder is zero.

I never used fdisk on a removeable disk as I only needed them for FreeBSD.
The follwoing always worked for me:
dd if=/dev/zero bs=10240 count=1 of=/dev/dax
disklabel -rw dax auto
disklabel -e dax

It looks like fdisk triggers the bug.

B.Walter              COSMO-Project         http://www.cosmo-project.de
[EMAIL PROTECTED]         Usergroup           [EMAIL PROTECTED]

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to