From: Bernd Walter <[EMAIL PROTECTED]>
Date: Wed, 7 Feb 2001 17:11:57 +0100
> On Tue, Feb 06, 2001 at 11:21:12PM +0900, [EMAIL PROTECTED] wrote:
> > Today I tried with 4.2-RELEASE (sorry not -current) and,
> > 1. Boot up the 4.2-RELEASE with GENERIC kernel.
> > 2. Connect MO drive with PC Card SCSI(ncv).
> > 3. Insert PC Card without medium in the MO drive.
> > 4. The pccardd automatically run camcontrol rescan.
> > 5. Message says that da0 is 0MB capacity.
> > 6. Run fdisk da0
> > 7. got panic with divided by zero. 
> > 
> > Probably divided by zero is caused at line 737 or 748 in the
> > scsi_low_action() in cam/scsi/scsi_low.c because of ccg->block_size or 
> > secs_per_cylinder is zero.

I tried with same drive and another SCSI card (ahc0) in
4.2-RELEASE. No problem were found. I watched the diffs between da.c
and od.c. It seems like some fault in scsi_low.c. Hmm, my fault....

Sorry for claiming `da'.

By the way, in Japanese users mailing list, some said that `da' does
not check whether a medium is writerable or not (write
protected). If you mount a write protected medium with -rw, it will
lead bad condition when you do umount. 

> I never used fdisk on a removeable disk as I only needed them for FreeBSD.
> It looks like fdisk triggers the bug.

I used fdisk just to check if there is a slice or not. Fdisk did not
make problem.

// Noriaki Mitsunaga //

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to