On 21-Apr-01 David W. Chapman Jr. wrote:
> I just tried to do an installkernel on a new kernel I built and I got the
> same error except the last line changed to
> stopped at    ffs_dirpref+0x210    movzbl    0(%ECX,%EAX,1),%EAX
> Do I have any hope at recovering from this or should I start again with 4
> and upgrade to -current.  I'm assuming is a problem with the kernel and
> without being able to update the kernel and install a new one, I don't think
> I can fix it.

You need to rebuild fsck and install it and fsck your filesystems.  This is the
dirpref changes biting you.  Warner, we probably need an entry in UPDATING for
the dirpref changes that warn people to build and install a new fsck before
booting a dirpref kernel.


John Baldwin <[EMAIL PROTECTED]> -- http://www.FreeBSD.org/~jhb/
PGP Key: http://www.Baldwin.cx/~john/pgpkey.asc
"Power Users Use the Power to Serve!"  -  http://www.FreeBSD.org/

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to