This is today's -CURRENT:

FreeBSD 5.0-CURRENT FreeBSD 5.0-CURRENT #64: Mon May 14 09:06:50 PDT 
2001     root@localhost:/common/C/obj/usr/src/sys/LAPTOP_30W  i386

Earlier today, I built -STABLE:

FreeBSD 4.3-STABLE FreeBSD 4.3-STABLE #49: Mon May 14 06:37:18 PDT 
2001     [EMAIL PROTECTED]:/common/S1/obj/usr/src/sys/LAPTOP_30W  i386

and it seems OK.

Built -CURRENT & rebooted after mergemaster as usual, and some X
applications (xbattbar; xlockmore; oclock) work OK, but no xterm.  At
least, not from X (XF86-4.0.3).  I tried using Ctl-Alt-F2 to get to
a non-X login, logged in , set DISPLAY to m147:0.0, issued "xterm &",
and got an xterm OK.

Once I did that, I could start another xterm from that one.  Sounds
as if something's hosed $DISPLAY... but then why would other X apps
display OK?  (I just checked; xfig & xv come up fine, direct from the
tvtwm menu.)

So I tried "cd /usr/ports/x11/XFree86-4; sudo make reinstall"; that
done, I re-booted.  Still no joy.

So... I wouldn't normally sent this to the -current list, but I'm
rather at a loss, and as far as I can tell, the difference would seem to
have been a recent one in -CURRENT -- after all, I have been tracking
each of -STABLE and -CURRENT daily (including the weekends, yes).

The one other thing that appears to be fairly bogus (and possibly
related) is that although I was prompted for my SSH "passphrase" in
.xsession as usual, today (for the first time that I can recall), I see
the following:

m147[14] ssh-add -l
Could not open a connection to your authentication agent.

Normally, I see something indicating that ssh-agent "did the right
thing" for me....

Now, in order to get -CURRENT to build yesterday, I had patched
src/usr.sbin/kbdcontrol/kbdcontrol.c at revision 1.34 (patch sent out by
John Hay), then did a "make all install" from the src/usr.sbin/kbdcontrol
directory, then a "make buildworld" sequence from /usr/src.

This morning, I see that sobomax patched
src/usr.sbin/kbdcontrol/kbdcontrol.c to revision 1.35, so I blew away my
patched version & re-synced it with the repostory (revision 1.35) before
the "make buildworld".

Maybe I need to re-build world...??!???  (I recall that (part of?) the
issue with yesterday's breakage was that the "make dependencies" uses
some userland programs, /usr/sbin/kbdcontrol among them.....)

David H. Wolfskill                              [EMAIL PROTECTED]
As a computing professional, I believe it would be unethical for me to
advise, recommend, or support the use (save possibly for personal
amusement) of any product that is or depends on any Microsoft product.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to